Mini 2 will not land

Auto or manual
When I try auto it says not suitable for landing. It’s a smooth concrete driveway.
Then I can’t even land it manually. It hovers about 2’ off the ground
Only when I try auto land again it asks if landing surface is ok and when I say yes it will land.

Have you tried landing on a different surface?

Yes, After further research it seems to be normal with precision take off and landing.
One person said to hold the stick down until it says landing.
I thought that would shut the motors down

You are thinking of the emergency motor shut-off which as I remember takes both sticks pulled inward and downward at a 45 degree angle.

If you are thinking of using this, DO NOT!!! There are plenty of videos with this being tested. My own experience is IT IS DANGEROUS for you, any by-standers, and your poor little drone.

When you move the Left Stick Down and Right and you move the Right Stick Down and Left, the flight controller immediately tries to execute your flight commands and it takes a bit before the flight controller says, “Holy S&%t, I’m suppose to shut the motors down…”

Before it realizes you are trying to shut it down, the flight controller is trying to (Left Stick) drop altitude and yaw right and the flight controller is trying to (Right Stick) pitch left and reverse…

And it ain’t pretty, most likely since your drone is only a few feet off the pavement (ground), it’s going to crash with the motors still cranking out full power…

In the YouTube Videos, some folk have put “rescue folks” out in the yard holding a blanket and when they hit Emergency Stop with the drone up high, the Drone usually zips right then left spinning as it falls to the ground, leaving the rescue folks scrambling to get under the drone with the blanket trying to catch before it hit the ground.

Some Tubers have killed the motors up high, then release the sticks to see if the drone, as it tumbles, will restart its motors and recover. Some say it will recover in about 30-or so feet. Some send their drones back for Care Refresh Replacement…

You need to practice the landing with just the Left Stick causing the landing, your need to practice the auto landing, and your need to learn to hand launch and hand land…

YouTube is a great source for Good and Bad Advice… Watch both, this way you’ll know what to do and what not to do…

1 Like

I’ve been flying since the first phantom 1 came out
It will not auto land
It will not land manually
I can hand catch on yachts in the ocean
The left stick will NOT let it land
Only way it will land is 2nd time I tap auto land and still asks if landing area is ok

Ok, from what you describe, it sounds like it’s Mechanical or Firmware/Software and if it persists you could find yourself out, someplace, out of reach, over trees or water and it will not respond and you will be stuck watching it hover until the battery runs out and it just settles down, in a tree, a pond, a roadway.

Maybe it’s time to send it in for service.

A better starting suggestion as opposed to all of the proposed testing would be to supply a flight log from any of the flights that exhibit the issue and allow those who analyze the data to have a look and see what the issue may be. It could be something as simple as stick calibration, or something else. I find it best to utilize available assets to determine an issue before attempting any repair or service.

Better Advice than mine… For me to suggest this is like “living in a glass house and throwing rocks…” I have no skills, abilities, or knowledge on how to analyze the flight logs so that advice from me would be useless…

I forget how to get to the flight logs but I use airdata and it says what notifications were at landing
I need to find out what tripod means lol

Seems to be common


If you make your Airdata logs fully sharable, and place a link here. The log file can be directly downloaded from there. Alternatively, you can upload the log to Phantom Help here: Log Upload and share a link to that back here on this thread.

I found the flight logs but they are from my mavic pro from 2018 to 2020.
Nothing for my mini 2
Be patient
I’m working on it lol

No rush…Take your time. Like I mentioned though since you are using Airdata you can share the link here as well. That may be easier than searching for the ones you want. If you do that however, you need to make sure its fully sharable. Otherwise the download of the actual log will not be available.

I just did a quick flight and I am on auto sync and nothing is showing up in the flight logs
Here is the airdata link
It did the same thing. I hit auto land and it dropped down from about 8’ to 1’ and stopped. I couldn’t manual land. I hit auto land again and it asked to confirm and it landed
Jun 1st, 2022 02:42PM | General / Overview | DJI Fly log 1.5.10 | United States | Airdata UAV

Hmmm… The data matches up with your flight description/issue but I am not seeing a lot here to
indicate exactly what the issue may be. If you look at the chart below you will see that it matches your
description. The only possibility, other that ground clutter of some sort that I can think of is when you cancelled the first autoland, and tried to land manually, the mode did not " fully" change and the aircraft actually remained in autoland mode. I may be wrong but I don’t think you can use the throttle in autoland mode after you confirm it. Although, granted you did not confirm the first one, even though you did activate it.

To test that theory, try another short flight as you did for this one but use ONLY manual control for takeoff and landing. If the issue goes away using only manual, that indicates an issue with the Fly App and/or the aircraft itself ( Possibly the VPS ). Additionally, ensure your takeoff and landing spot is linear.

Appreciate the help.
Did a similar flight. The landing area is a pool deck so there’s no obstructions of any kind.
Did the manual take off.
Manual landing was doing great and then stopped about 2’ off the ground. No warnings. I tried moving around but it would not descend any further
I had to use auto land and then it asked me to confirm landing area was clear and then it landed and shut down

See if you can find the original .txt log on your device and upload that to the link I provided earlier. Then share a link back here to that. Some of the data fields are missing from the Airdata download version. That may help a little more.

This second flight is identical in VPS altitude when attempting to land. 1.6 FT exactly the same as the first flight. That is very odd. This to me, and again I could be wrong, is looking like a firmware bug. For some reason when the VPS indicates 1.6 FT, it will not allow the aircraft to land manually. Have you made any firmware changes?

I’ve only had it for a bout a month and everything updated when I first turned it on.
I also installed Go Fly at that time.
For some reason the flight records aren’t showing up for the mini 2.
I just flew my P3A on the same flight and the flight record shows up
This should be for the mini 2
Not sure why flight records don’t sync with the mini 2 but it does for the P3A.