Mini 2 will not land

This should be for the P3A

The P3A data is normal. The mini has far more sensors than the P3A, so you have to take that in the equation. The most recent firmware versions for the mini are: V01.04.0000 aircraft and V04.11.0032 remote controller firmware. Personally, I do not like firmware updates. They tend to be more trouble than they are worth. But if indeed it is a firmware bug as I suspect, you can try that if you are not on the above versions.

Long story short but that P3A I bought used and it’s never been updated since new.
I had a hard time with the mavic pro on the big boat with the engines and generators running and sold it and went back to the tried and true P3A.
Got these cool whale videos with the P3A using avegant glyph goggles

watch @2:50 mark when papa whale surfaces

Nor has my P3A…It still has the original firmware from 2018…And still flies like it was new. As I said though, there are so many new sensors on the newer aircraft that firmware issues can cause numerous different issues. Personally, I never recommend a firmware upgrade unless there is an issue that cant be solved otherwise. I still say that there is a firmware issue with the Mini. Primarily associated with the VPS is my guess. I see no other reason that the aircraft will not land manually, when the VPS appears to be working as it should. Great shots BTW…From the P3A…

1 Like