DJI Drone Help Forum

Mavic 2 Flyaway - Lost Drone - Help

Hi,

This is my first post however I’d have hoped my first post wouldn’t have been regarding the loss of my drone. I really would appreciate any help or light anyone may be able to provide. I’m in complete dispare that I’ve lost my drone.

I was flying my drone yesterday afternoon whilst on holiday in Portugal when it seems to have malfunctioned lost connection and disappeared.

My drone had only just taken off (20 or so seconds into flight) with a fully charged battery when around 200ft away and still within visual line of sight from the take off position it began to make a strange noise and then disappeared out of sight. It sounded as though the motors suddenly and rapidly increased in speed and malfunctioned even though i had just began to reduce a little height.

I have been unable to locate the drone after spending a full day searching for for it in within a wide area under the location it was last seen above. I have also used the locate my drone function within the app however this has also proven unsuccessful. The last known location appears to be where the drone lost contact with controller over 200ft in the air and around 200ft away from takeoff position, traveling directly ahead of my location.

The weather was perfect for flying, clear visibility, dry, blue skies, satalites locked on and very little wind.

I had began my flight by competing a pre flight health check of the drone, fusilage, arms, rotors and gimbal. I then took off completed a manouver check as I always do after takeoff and before flying off. A simple hover then left right, back forwards, up and down to ensure the aircraft is responding correctly. The drone was working as expected at this stage.

I then proceeded to fly towards the intended target of interest (an old farm outhouse) to capture with photo / video. I was pushing forwards on both the left and right controls to gain height and move forwards. Just as I approached the hotel perimeter bushes (these are around 7-10ft ) and was about to enter the overgrown wasteland beyond the hotel perimeter I began looking at my phone screen connected to the controller to line up my camera with the subject to start filming. At this point I decided to start to reduce my height as I was around 200ft above ground level and well above the tallest bushes and trees in the area of wasteland. The bushes and small trees would be no more than 15-20 ft tall as a maximum. Throughout the flight I remained fully within VLOS.

As I pulled down on the controller to reduce a little height as I approached the old farm outhouse I heard the motors produce a sound I can only describe as sudden overspeed as if the motors were malfunctioning (this was not a sound I had heard the drone make before in any of my flights).

At the same moment the controller disconnected and I then immediately looked up but the drone had disappeared. I cannot confirm if the drone continued to fly away or of it plumented to the ground. I could hear no thud of hitting ground or rustling if the drone had falllen into a tree. The last image on my remote was in black and white (as disconected). The image was level and suggested no change in direction still around 200 ft above ground maintaing a heading towards the target subject. I attempted to press the return home button on the remote however this did not work. (I have used this before and understand how this operates). I waited for 40 minutes in the event the drone returned home itself. The drone did not return. I then scoured the area under the drone where it had last been seen. This was both within the hotel boundaries and the wasteland beyond the hotel perimeter. This proved difficult due to fences, uneven terrain and inaccessible areas due to shrubbery, trees etc.

The wasteland was long grass (3ft or so with patches of dry soil, shrubbery, scattered with the odd tree 15-20ft in height with no electrical devices to cause interference on the ground and no power cables in the area. (There appears to have been a malfunction of software or hardware disconecting the aircraft from controller and causing the loss and flyaway of the drone.

This was my last day of holiday with my family and I have now returned home today. As such I am unable to continue a further search. Searching at the time was dangerous as I was told wild dogs and snakes lived within the wasteland and I should not enter. Regardless of this I spent my final day of holiday searching frantically for my drone with no luck.

Please may I ask your thoughts on this. I have tried to attach the flight record however as I’m a new user here it won’t allow me to do so.

I feel that this was a malfunction and the drone failed to operate as intended.

I’ve emailed DJI this morning however I’m currently awaiting their response. Would have emailed sooner however due to travel home I only got home around half 4 this morning. Drive home from Birmingham airport to Newcastle area.

Appreciate anyone’s help on this.

Kind regards,

Chris Dodds

We will need to see the flight log to assist you. Simple words can not explain the incident fully.
Upload your device flight log to the link below and post a link back here to that and we can have a look.
( Instructions are on the link )
Log Viewer

1 Like

Thanks for your repsonse.

Here’s a link to the flight record

https://www.phantomhelp.com/LogViewer/DEEK97M58P898X6WTMVO/

I tried earlier to upload the file but it wouldn’t allow.

Thanks again.

Looking at this data there is nothing blatantly obvious as far as a malfunction goes. Everything appeared normal until you lost signal. That being said, at ~20 seconds, you were flying at full throttle and full elevator at a speed of roughly 20mph. You then for some unknown reason gave full throttle down. The data ends one second later. I suspect that DJI upon review of this data will claim this was pure pilot error. I cannot confirm that, but giving full throttle down at high speed and full elevator could have devastating consequences. Not only stressing the aircraft, but possibly dislodging the battery. This is only an initial look, others may see this differently.

Thanks for your response Fly_Dawg, I very much appreciate it.

I am certain that just after loosing connection I heard the motor speed rapidly increase. Like a motor went into an overspeed. The sound was out of synch with the other motor speed I could hear. How may this be explained if if the power had been disconected?

The aircraft was traveling at 17.5mph, less than half of its maximum operating speed. If this is the case then it would indicate the aircraft has failed well within its tolerances. As a pilot I would not expect the aircraft to over stress simply changing from ascending to descending whilst continuing on the same course direction. This change in input was over half of a second, not overly rapid. Surely this level of stress would be factored in for users operating within Sports mode?

From this data, the motor “sound” that you heard was most likely due to the fact that at signal loss you were applying full down throttle ( Slowing the motors significantly to almost an idle state ). Once the signal was lost the aircraft throttled back up quickly to “hover” speed and coming nto a quick stop to hover. That would explain the sound. I have not seen this with a Mavic, however there have been many a P4 lost due to a battery disconnect. Some due to over steering, and hard braking at high speed, others for unknown reasons. The power disconnect you referred to ( If it occurred ) would have been right at the end of the data, which would also explain the “motor sound” immediately preceding that event.

Thanks again Fly_Dawg.

If this is the case, if the aircraft has been programmed / designed to come to an abrupt stop and hover if signal is lost surely it is a design fault with the battery clips if this has disconected when performing this manouver.

It would be expected that the aircraft can withstand and enter (into a saftey protocol) an abrupt hover at any speed up to its maximum velocity. Presumably this would have been tested when implementing this auto flight programme.

If this was the cause of incident, the aircraft traveling at a speed 17.5mph would point a fault with the battery connection / clips not being able to withstand less than half the aircraft’s max speed. The power supply should remain in place. This should be well within the designed saftey tolerances of the aircraft to withstand this manouver. Especially as the aircraft was not also performing any harsh banking or experiencing any strong winds at the time.

If the case, this would likley raise a serious safety concern for other pilots using these drones recreationally and commercially. This would suggest the aircraft is not safe when traveling well within tolerances and a failure of this sort could occur if signal is lost, even momentarily.

This is true. It is not an issue with the Mavic, however the P3’s can loose a prop with the abrupt stops. Just throwing that out for reference. The aircraft will come to an abrupt stop at full signal loss. What should occur after the stop would be approximately 2 seconds after signal loss, if the failsafe is RTH, then this should activate. This is why I suspect a power loss of some sort, possibly due to the final maneuver in the log file, in addition to the fact that you were well within full signal range, unless the trees were blocking your signal. Without additional data to go by, one can only speculate what actually occurred after the log ended. The aircraft log would be needed for that. I am simply attempting to relay what DJI may or may not do for you. Generally speaking, they usually will require the aircraft for any type of replacement, although there have been cases where the device log was enough. I don’t think there is enough data here for a successful claim with DJI. I could be wrong and it may be worth pursuing that but that is only my opinion.

I appreciate we are simply speculating at this stage and I apprciate your thoughts on this.

However I think if this has been the cause of incident it is very difficult to accept that the aircraft can fail at less than 40% of its operating window (speed) when performing a saftey protocol which DJI have put in place. If this is the case then DJI need to re-examine and reprogramme the coding to bring the aircraft to a smoother stop before hovering. This fault would lie with them as the saftey system is not fit for purpose and poorly designed in relation to the harware (battery clips) The sensors should play part also here as nothing was in obstruction to require an immediate and harsh halt on this occasion. A gradual stop within a defined distance would work better if risk of disconnection exists.

It would be more understandable if the aircraft had failed in the respect we have discussed whilst being flown at and beyond the optimum thresholds. Surely Sports mode has been designed and implemented with this in mind.

Considering the factors this aircraft was within 40% of its operating speed in a straight line, something is fundamentally and worryingly wrong with both the software and hardware if this is the cause.

I’m am curious to hear what DJI will respond. I’m sure the CAA would be keen to know that this type aircraft can fail well within its quoted tolerances if this is the case, whilst completing a very basic manouver.

I appreciate DJI may wish to inspect the aircraft however due to the circumstances of the terrain and the day I spent searching it was not possible to find and recover. Not all crashes will permit safe location and recover and this is what DJI must take into consideration the saftey of their customers. It’s not as if the find my drone option was working to assist here as this function only shows the same last pinpoint on the flight data.

This is already provided in the app for braking adjustments.

As I mentioned with the P4’s, the version 2 of the P4 added a battery latch sensor in order to reduce the error of improper seating of the battery. It is obvious to me ( Again my opinion ) that DJI was aware there was an issue of some sort. Why else would they add the latch sensor?

Agreed on these points.

One last note to point out that “could” be a factor. According to specs, the maximum pitch angle is 25 degrees. While flying at full elevator you were pitched down at ~16 degrees. When you moved the throttle from full up to full down, the aircraft was pitched at ~ 22 degrees when the data ended. It is quite possible that you exceeded the 25 degree point. As to the effects of such a pitch change I can’t answer. But it is most definitely close, if not surpassing the 25 degrees after the end of the data.

If it turns out the battery has disconnected then there has been a definite design oversight by DJI. As you mention the P4 had a design review come V2 and I agree they must have known there was an issue in order to do this. The main factor of this would be as a saftey precaution to avoid potential legal action and liabilities against them if the worst were to occur. Dead weight dropping on someones head / property.

As discussed above (regarding the phantom range) it is plausible that there may also be design and software flaws / issues present within the Mavic 2, capable of over compensating / conflicting with pilot inputs and resulting in a lost / crashed aircraft. This would not be pilot error but an issue with software conflicting with input. Without conflict a drone in this situation would not be lost or crash.

I have seen nothing within the manual / literature suggesting going from full stick one way to full reverse as not advised. It is entirely likley that such a movement may be necessary In emergencies to avoid collision or contact. Would they then suggest that this action is not advised or possible?

If so then they would need to revise their ops manual and also release a statement advising against this type of manouver. I would not expect to have to alter core settings for flying the aircraft well within the tollerances.

The aircraft should not place itself into a potentially critical position by taking a basic pre programmed manouver. After all this is meant to be in place as a saftey measure and should not present the slightest of risk to dowing the aircraft regardless of whether these settings have been adjusted or not. The aircraft should respond appropriately and safely dependant on real time factors such as current speed, tilt angle etc. Otherwise the system is naive to react the same in all situations.

Regarding pitch angle. The aircraft is capable of achieving a 35° angle within S mode and 25° in P mode. If 25° were to have been exceeded which it wasn’t here at 22° the aircraft should easily be able to cope especially at less than 40% top speed in a straight line with minimal wind conditions. All we know is it was within pitch tollerances before the data ends. The aircraft was operating within the envilope of pre defined tolerances and has possibly failed due to the factors we have discussed above.

On the data that is present the pilot input / human factors were within tolerances and there is no advice I can see to avoid changing ascent to descent in the manor actioned. Besides this alone would would surely unlikley have caused the incident considering the speed and capabilities of the aircraft. The drones flight path remained in line of sight the whole flight and there was no obstruction to cause sudden disconection. I’m still unsure of why the aircraft disconnected at all. It seems as though disconnection coincides at point of data ending. Why did this occur?

Also from what we have discussed, if the fail safe hover is to blame in theory of dislodging the battery, if this were not to have kicked in so harshly and the drone were to have recated more appropriately to conditions I would likley still be in possession.

I think we need to get a few more eyes on this data, such that it is. My point being in what I described is the fact that I have never seen a log indicating full elevator, full throttle, then the quick full throttle down ( At least I don’t recall if I have ) so I cannot say with any degree of confidence that it was an actual “cause” of the incident. This was only a data point that I brought up. So if @sar104 and/or @msinger and/or @BudWalker could take a look as well, maybe we can come to some sort of reasoning. As it stands, it could be any number of possibilities, but it is quite unusual to lose signal so close in. As mentioned previously, the aircraft file would be more useful, but obviously that is not a possibility at this point.

Thanks again Fly_Dawg, I appreciate your thoughts and for asking the others to cast their eye over this too.

It’ll be good to see what others may decipher from the data.

If DJI advised against doing it, they would likely have mentioned it in the Mavic manual. I don’t think this caused your issue.

I reviewed the data in your flight log and did not see anything unusual. Since the drone is programmed to fly back to the home point even in the case of a software or remote controller malfunction, neither could have caused this issue. One of the following most likely occurred:

  • The battery was not snapped into place on both sides and disconnected at the end of your flight log.

  • The battery was damaged and/or faulty and shut off at the end of your flight log.

  • Some other battery related hardware failed and caused the drone to power down at the end of the flight log.

Whatever the case, your drone likely crashed somewhere in this yellow box:

1 Like

Thanks @msinger for your thoughts and time on this.

Before each flight I make a point of clipping the battery in with both thumbs ensuing correctly located and firmly in place before takeoff so wouldnt be sure how it would become dislodged.

Would the battery have shown any signs of failure prior to failing? Power flow / volts dont seem to be erratic and discharge looks even. Is it possible for a battery to suddenly and instantly fail, one moment operating fine and next not? The battery is relatively new with a low number of charge cycles and had been well looked after.

There was a sudden increase in motor speed just a moment prior to dissapearance. Would a battery failure cause a potential surge of power, perhaps why I heard the motor(s) suddenly increase in speed before it dissapeared?

What other battery related hardware could have failed?

Really appreciate you taking the time to produce the likley crash site image above. The area within the outline is a dense area of trees and long grass. I had been searching within a much larger area, but also searched this area with no luck.

The abrupt disconnect suggests that there was some kind of failure. It might have been a battery disconnect, but it’s also possibly another case of a flight maneuver that caused an extreme enough pitch excursion (> 70°) to result in the FC shutting down the motors. Looking at the pitch values when the throttle went from full up to full down:

If that excursion kept going and the motors shut down then obviously it will fall to the ground. That path can be predicted with a simple drag model for the M2 combined with initial altitude, velocity, wind speed and direction (5.5 m/s @ 187°), and yields the following:

Plotting that trajectory in Google Earth:

It’s probably worth a good look at that location.

I don’t think this was the case. When the motors shut off like that, OSD.isMotorUp switches to FALSE in the last flight log entry.

Wouldn’t that tell you that the motors were off? Which is what was mentioned? I did not see that until you mentioned it.

When the motors shut off, OSD.isMotorUp switches to FALSE. In this case, that value was set to TRUE the entire time. That means the motors were on until sometime after the downlink disconnected.

If you’re sure the battery was clipped in properly, then the battery probably did not disconnect at the battery terminals.

It depends on how a battery fails. In a case of an instant disconnect, the flight log usually looks like your log above.

Possible? Yes. Probable? No.

No. That sound was probably caused by your throttle adjustment.

I’m not sure since I don’t have a deep understanding of the inner workings of the Mavic 2.