DJI Drone Help Forum

Lost Spark ...and FOUND it thanks to this forum contributors!

I flew earlier today no problem, RTH worked fine and pleasant afternoon. This evening different location, RTH active…Spark goes off …I press RTH…and I can hear it in the distance but it is not coming back…cancelled and try to see if I could guide it back…no way…press RTH says RTH initiated, but not coming back.

Runs out of juice and gone it is.

I am looking at my LOGS in DJI Go 4 I see the afternoon logs , but cannot see the evening LOGs…New to this ( 4 days)…I might not be looking in the right place.

Can anyone help me pinpoint the possible location of the drone…which to boot is in a forest…?

Thanking you in advance for any possible help and guidance as to what I need to upload and where to find it.

The only way for anyone to help you is to upload your logs from today. I would suggest you start here and we can go from there. Instructions are on the link: Log Viewer If you need assistance after the upload, place a link back here to your uploaded log.

Thank you kindly for guiding me in the right direction and for your precious time. I’ll admit that I am quite surprise to see the statement in the log and scratching my head as to how it got so far away from me…

https://www.phantomhelp.com/LogViewer/5WFW1POH079L0E88L4W0/

Hi Toxie,

Strange flightlog, does not start at the beginning of your flight.
Spark auto landed (see the map), hope you can find it there.

cheers
JJB

1 Like

The last recorded height was 12.8 meters. The Smart Battery system was directing the Spark to land. But, the Spark was not descending in place. At times it seemed to have been drifting and other times attempting to GoHome. The descent rate was around 1 m/s and couldn’t have gone far. Take a look here

For some reason the full flight log is on 3 separate txt files, I provided the last one for I assumed it to be the most relevant to this issue.

I looked at the second by second action in the description and it makes no senses as it pertain to what it did …3 times it recognises the RTH…and does nothing,in fact on the lkast request it flies away as oppose to coming home.

I looked into ‘find my drone’ in the APP which provides for a similar map as the one you posted, and just back from searching that general area for 2 hrs with no luck. I’ll get a GPS positioning APP for my phone and enter the coordinate and see if it gets me any closer…

There is obviously something really screwie with all of this…very very strange. I even tried to get control back on a couple of occasion to no avail…

Thank you for you time…

This is most likely due to signal loss. Once the RC re-acquires, a new .txt file is started. The odd thing is, this only happens with complete signal loss.

Is it possible that you had you loss of signal action set to “hover”? That would explain why it did nothing.

Hi,

Must have been the wind, drone did face home direction but when with pitch down angles slowly backwards…
If seen in the app (check distance decreasing on RTH), if possible lower height (less wind) and/or cancel RTH, switch Sports mode and fully fwd!

Your fail safe RTH was set to Return to Home.

cheers
JJB

It does appear that wind was an issue, however your elevator inputs did not help matters. You were flying the aircraft away from you as well it appears. Note the distance increase during auto land specifically.

To make it easier to see…

10 times aft pitch, while aircraft heading towards home.
Lower red lines in the chart are like this becauce AC speed was slow.
(move heading = drone heading = flying drone heading…)

cheers
JJB

Enter 46.01588296, -74.0618624 into the map app on your mobile device and start searching near that location.

While the Spark was landing, the downward sensors detected an obstacle about 23 feet above the ground. So, it could be stuck up in a tree.

@Fly_Dawg , @JJB why do you guys think that wind was an issue? Looking at the first attempt to RTH it’s apparent that the FC is causing the Spark not to continue towards Home. There is the initial pitch down to -27° but then slowly relaxes that to -19°. After that it pitches up to stop the forward progress to Home. If it were fighting a head wind it would have kept the pitch down.

In that interval the Spark moved from here
image

to here
image

I.e., it do move towards home.

I was specifically looking at the third attempt. The aircraft appears to be picthing up and down at a semi regular interval, as distance increases with no inputs from the OP. That is where I suggested a wind factor.

Thank you all for your great response and support…I will go back in that area tomorrow morning.

Thinking of why tthe log is split in 3 txt file…i did loose connection once so this could explain 1 log…not sure why I have 3.

Wind indeed was a sure issue…which picked up suddenly and that’s why I tried to bring it back to no avail…

Exactly. If the wind was too strong to allow it to make progress towards home the pitch would have remained pitch down. All 3 RTH are similar in this regard.

1 Like

Well I elected to go take a second look tonight with the additional info you guys provided, to msinger a special thank you for the more refine GPS location.

I found Sparky perch 20 some feet up in a tree in a perfect landing position…shock the tree and caught it and it is working fine.

Talk about an adventure…again a BIG BIG thank you for your help and support.

1 Like

===================
I do not see this option in DJI Go 4 ???

Well then. Could you retrieve the .DAT from the Spark? We’re interested to see why the RTH didn’t work and the .DAT should tell us.

Follow these instructions
Retrieving a V3 .DAT File from the AC
and upload to a sharing site like Dropbox.

Thank you for your help.

The file you submitted, dji_assistant_export_file_2019-06-06_09-47-49.dat, contained FLY094.DAT. The one we need is FLY104.DAT.