DJI Drone Help Forum

DJI Phantom Remote Controller Compatibility Chart

#1

Greetings Phantom Pilots!
I found an RC Compatibility Chart on the PhantomHelp.com web page:

Link:DJI Phantom Remote Controller Compatibility Chart

The chart shows the Inspire RC is compatible with the P4. Does
anyone have a tutorial on how to
link a GL658 series RC with a P4?
I tried FW roll backs, but no luck.
Thanks in advance!
Mark

0 Likes

#2

It should link the same way a P4 remote controller links to the P4.

0 Likes

#3

Hello msinger,
Thank you so much for replying!
I see your name on the compatibility
list. Do you have background on how
this list was compiled? I called dji
support for help linking a GL658 to
the P4 and they said it can’t be done.
I was told only the GL300C will work
with the P4. But wait a minute … I
have a P4 linked to a GL300B!

I read on the web that the 300C is a bit
of a lemon compared to some
of the other controllers on your list.

What’s the trick to linking GL658 series
RC to the P4 AC?

Many thanks!
Mark

0 Likes

#4

The list was originally compiled by Oso. I made some corrections to it and added more information to it.

Yes, DJI support will normally only rattle off whatever is displayed in the DJI store or other documentation on the DJI website.

I only own the GL658C, so that’s the only Inspire remote controller I was able to try linking to my P4. Do you have a P4… and not a P4A, P4P, or P4PV2?

0 Likes

#5

Yes, it’s a Phantom 4 original not the pro.
Are you able to get dji go 4 to recognize
the RC?

0 Likes

#6

Yes, I can link my P4 to my GL658C. Here are my current firmware versions:

P4: 2.00.0700
GL658C: 1.7.80

0 Likes

#7

Cool! I must be close to making it work. I’m stuck at trying to upgrade/downgrade my controller firmware. I have 2 GL658C controllers. I’m not able to open dji 4 with either one. When I connect the R.C. to my android and try to open dji 4, I get the message that the Inspire RC is not compatible with dji 4, and it defaults to dji go (before P4).
Here’s what I get at the dji Go
FW downgrade screen:

0 Likes

#8

DJI GO only allows the firmware to be downgraded to a certain point. If you want to go below that, I believe the DankDroneDownloader is the only option.

Here’s a video that shows how this tool works:

0 Likes

#9

Thank you! So close now … But Win 10 seems to be holding me up. I unzipped Dumldore 3.1 into a new folder, plugged my RC into the computer’s usb, turned on the RC, waited for windows to recognize it, and opened the Dumldore program.

I clicked on “down load firmware” and it takes me back to github. I did not see a link for fw?

0 Likes

#10

When I close Dumldore I get this message:

win%20error

0 Likes

#11

I was thinking DUMLdore could be used to load the BIN downloaded from DankDroneDownloader, but that’s not going to work since DUMLdore cannot connect to the Inspire 1 remote controller.

In your FW downgrade screen above, was that from DJI GO 3 or DJI GO 4? If you were using DJI GO 4, try downgrading the firmware with DJI GO 3.

0 Likes

#12

msinger,
Thanks for the help. dji go 3 recognizes it’s an Inspire controller, but I get the error posted earlier. dji go 4 only sends me to dji go 3.

0 Likes

#13

Hey! We’re getting closer … I have the P4 fw 2.00.0700. The last piece is the gl658c 1.7.80. Google can’t find it.

I’ll call dji tomorrow, surely they’ll be a huge help!
Thanks again …

0 Likes

#14

Are you able to bind either one of your GL658C remote controllers to an Inspire 1?

0 Likes

#15

Success!

0 Likes

#16

How did you resolve the issue?

0 Likes

#17

.msinger, many thanks! I started this journey after seeing your RC Compatibility Chart. If someone on the web says it’ll work;
then ….”

It took me several steps (and mis-steps) to get this to work. Here’s the twisted path I took:

Our family got started flying drones at the request of my Mom. It was on her bucket list to fly RC Aircraft. I couldn’t afford to buy everyone a brand new drone, so the deal hunting begins! We were able to find used Phantom 3s at a reasonable price. We are now upgrading to Phantom 4s. (used P4s!)

There is a lot of talk about the limited capability of the GL300C RCs. After hearing about the GL658 series RC, I had to find out more. The same Part #54 HDMI Output Module that the Phantom3 uses comes stock on the GL658! That alone sold me on the idea.

#1: Performed factory resets. The GL658 can be reset by pushing C1, C2 (backside of controller), and the record button (red button on left side of RC). I tried resetting the P4 in dji Assistant 2 … no luck.

#2: What Firmware to use? msinger shared this setup: V1.7.80 for the RC, and V2.00.0700 for the AC. Since I was not able to change the AC FW, I was stuck with V01.00.016 for the AC. (There’s another FW that is now verified to work!)

#3: One thing at a time! I knew the AC was good to go (already flown with a GL300C). My first attempt was to just link RC and AC as is. The problem is the RC and AC are from two different families. The RC works with dji Go3, and the AC works in dji Go4. Try as I might, I could not get dji Go4 to recognize the RC. The RC reset was needed to access dji Go3. (before the reset I got the error “disconnected”) Once the RC was connected to dji Go3, I rolled back the firmware to V1.7.80. (at the first screen, before the flight program opens click and hold down the mouse button on the bars at the upper right side of the screen and choose the FW to roll back to from the drop down).

#4: GL658 does not want to open in dji Go4. With AC turned off, open dji Go3. You should see “Connected to Radio Control, Please connect Air Craft”. Click on “Camera” to open dji Go3. Click on the RC icon on the top bar. Under “Status” my RC was set to “Off”. I changed it to “Master”.

#5: With the RC still connected and the flight window open and the A.C. fired up, click on the RC icon on the top of the page and try to link the A.C. At this point dji Go3 closed automatically and dji4 opened. The green A.C. connected banner lit up and dji said: “home point updated”! Voila!!! At this point it was 10:30pm, I had spent several late nights fighting with this, I sent msinger a note “Success!” and went to bed. 10 minutes later I was outside enjoying a well deserved maiden flight! And THEN I had a good nights sleep!

#6: Post flight I restarted the A.C. and R.C. to see if I could link again. This time I was asked if I wanted to open dji Go3 or dji Go4. I selected dji Go4 and put a check in the box to make dji Go4 the default program. Dji Go4 recognized my controller. I did a standard link through the R.C. tab and the beeping started. After pushing the AC restart button, I pushed the button on the right side of the R.C. and presto! It linked up!!! Since then I have tried more restarts. Dji Go4 now boots straight up and I get green lights (R.C. and A.C.) without going through link up.

This was written from memory today. I’ll verify and check this info tonight.

Many thanks go to msinger. Your chart got me going on this crazy ride, and your input helped bring this to a successful conclusion!

Blue skies!!!
Mark

1 Like

#18

I didn’t even think about checking that setting. That was most likely the issue.

0 Likes