DJI Drone Help Forum

Controller Beeping Phantom 3 Pro


#21

I will ask again. Did you try the RC calibration in the link above?


#22

Yes I did, but could not accomplish as I cannot get to the camera settings. I o not think the controller is linking to the aircraft.


#23

You don’t need to be connected to the aircraft to calibrate the RC. Scroll across your screen until you find the P3P. Then press the camera button. It should then go to the camera view ( Which is blank obviously )…unless there is another issue with the RC. Note: There are drop down buttons above the aircraft photo to change aircraft.


#24

I’m sorry I am at a loss. All I can see on my iPhone is how to connect on the Phantom 3 Pro. I cannot get to the camera to calibrate.


#25

Did you try resetting your remote controller?


#26

I tried the controller reset procedure using the 4 buttons and did receive a light blue light but I was unable to connect the software on the phone. But it was quiet.


#27

Yes I did, and like I have said I cannot get to the camera. All the software does is tell me how to connect. I hit the equipment icon and nothing happens. So I cannot get to the camera.


#28

I did try resetting the controller using the 4 button method and got a light blue light. I then tried to activate thew DJI Go and as far as I could get was how to connect. Ihave been told to scroll across the screen and hit P3P but I am at a loss there because I don’t see anything like that on the how to connect screen or going back to the initial screen and hitting the icon for equipment which does nothing.


#29

Before you upgraded the firmware, were you able to get to the camera view in DJI GO?


#30

There could be another possibility. If either or both of the sticks are not functioning correctly then the beep could be a warning letting you know there is an issue with them. Rather like on the P3S controller, if you turn the remote on while the left stick is stuck in the down position … the remote will beep until you return the stick to the centre position.

Try doing a joystick calibration, doing this you will see if each stick has full range of movement. I did this recently with a remote I purchased second hand to upgrade but the remote wouldn’t start the P3S up. The calibration showed the right stick had full range of movement but only actually registered up and down, I did not recognise left or right movement. The minute I swopped the right stick out for a new (second hand) one … voila all was good. Cost me very little to repair rather than consign it to the bin. Now my P3S has 3 controllers each with a different mod.

Sorry if it has been mentioned before but always worth a try. Not everything is software / firmware related sometimes the physical parts do fail. Good luck, hope this helps.


#31

I was thinking the same thing. That’s why I asked the OP to try moving either stick above. If the sticks are out a calibration and either is moved, the beeping usually stops.


#32

I’ll re read all the thread again tomorrow when I’ve had some sleep lol lol, I’ll try and see if I can replicate the OP’s issue on my P3A RC and see what happens. I don’t know if it’s just me but I can’t help but think that either the OP has inadvertently missed or done something … but whatever it is will hopefully be a simple / easy fix. Is there anyone near them that could physically assist hands on … try another controller etc etc ? Go through trouble shooting exercises ? Makes me wish I was close so I could get my hands on it lol lol lol.


#33

My current thought is that the mobile device might not be connected to DJI GO. I’m still waiting for the OP to confirm that above. He didn’t mention if the remote controller ever successfully connected to DJI GO (even before the firmware update).


#34

Gentlemen, I do appreciate all the help. I have went back and tried to reset the controller. I used the second option,(turn on controller, let it start beeping, then press C1 and C2, video button and then G4?) and I can receive a blinking and beeping blur light. I then turn on aircraft and the gimble light is green, but the aircraft light is going between red and then green. Where do I go from there? I tried activating DJI Go then and still can only see how to connect. I cannot get to the camera view to calibrate the controller. The controller did work with the aircraft prior to me updating the software. You stated you was waiting for the OP to confirm your thoughts. May I ask what is the OP. I agree I don’t thing the controller is hooking up with the i Phone. Using my daughters Samsung when I boot the software, and launch DJI Go when it comes to the software i scan across to get to the Phantom the first aircraft it shows the camera view, not the how to connect view. But I cannot control any thing on the aircraft. If that makes any sense.


#35

OP is you, the Original Poster. You are in good hands with the people helping you out and I am confident they will help you sort everything out. Sorry I don’t have anything to add.

Good luck.

Chris


#36

Did you try doing the remote controller reset while connected to your daughter’s Samsung? The reset should force DJI GO to show you the prompt to update the remote controller firmware. That of course will only work if you’re able to get to the camera view.


#37

I just reloaded DJI Go on the Samsung and it still shows the camera view on the inspire series. Only get how to connect on the Phantom series. I attempted to reset the controller while using the Samsung but still to no avail. The only way I can get to a blinking blue light is ( and it is still constantly beeping) is holding C1 and C2 and then hitting the video along with G4. I can then let it continue to blink and beep, which after a bit (haven’t timed it) the controller shuts off totally.


#38

It sounds like you’ve exhausted all possibilities at this point. Reach out to DJI Support and see what they think.


#39

Thanking ya’ll for all the support and ideas. I tried everything I could. Anyhow I took your advice and sent them an email and we will go from there. I will make sure to keep every on apprised of the out come if I can.
Thanks once again


#40

Yes, please do let us know how you make out. Perhaps it’ll be helpful for someone else who is in the same situation. And I’m sure everyone who was helping out in this thread is interested in finding out what resolves your issue.