DJI Drone Help Forum

another p4a plus fell upside down from the heavens


#1

https://www.phantomhelp.com/LogViewer/043TXYBEWGWIWNV5HDKX/ data files
it is jailbroken however i read the data files from healty drone and seen nothing. can someone with more knowledge look this over


#2

Please provide the .DAT from the P4A. These instructions will show you how.
Retrieving a V3 .DAT File from the AC

It will be large so you’ll need to upload it to a shareable site like Dropbox or GoogleDrive and post a link to the uploaded .DAT.


#3

im uploading it now to dropbox. what do you need from there.


#4

#5

I believe this is the link to Dropbox.Not the specific link to the uploaded .DAT. @msinger


#6

do i need your email ?


#7

You need to create a shareable link in dropbox like this and post the link here.


#8

#9

https://drive.google.com/open?id=12T7-E4wdG9UQJgsojZQdSB-zJADXCPDj


#10

That’s the wrong .DAT. The one you want is FLY040.DAT


#11

https://drive.google.com/file/d/1hy16_GAFU9b5yL_VkmhXGr4X0wH1iLDr/view?usp=sharing


#12

@thepushercg…Well it certainly looks as though the motors shut down, but the battery was ok. May have to let @BudWalker take a look at this one. But will continue to look myself.

456.862 : 24104 [L-FMU/MOTOR] Stop. reason:roll over or atti fail
456.862 : 24104 [L-FMU/MOTOR]Total start times: 1, time: 457.00
456.863 : 24104 [L-PWM]set actuator mode:IDLE
456.864 : 24104 [L-FLYMODE]CTRL reset all by motor stopped
456.865 : 24104 [L-FLYMODE][ACT.msg] ACT_AUTO_LANDING can’t exec auto-landing while motor off
456.866 : 24104 [L-FMU/FSM]state changed. cur: motor off


#13

@thepushercg. Also, I think the reason the aicraft did not descend for auto landing, it also looks like an issue with the VPS. That would explain the stationary altitude I mentioned previously.

411.965 : 21859 [L-FLYMODE][Ctrl<8>] REQ_BATTERY AUTO_LANDING ctrl_auto_landing
412.225 : 21872 [L-FMU/LED]action changed. battery error!:.smart_capacity_level2_status(4)
412.584 : 21890 [L-RC]Start landing. rc vib!
412.883 : 21905 [L-RC]craft ctrl failed!!!
413.201 : 21921 [L-FMU/FSM]near ground
414.122 : 21967 [L-FMU/MOTOR]safe_near_grd:true
414.866 : 22004 [L-FMU/FSM]not near ground
414.903 : 22006 [L-RC]craft ctrl failed!!!
416.364 : 22079 [L-FMU/MOTOR]safe_near_grd:false
416.923 : 22107 [L-RC]craft ctrl failed!!!
418.943 : 22208 [L-RC]craft ctrl failed!!!
420.965 : 22309 [L-RC]craft ctrl failed!!!
422.001 : 22360 [L-FMU/FSM]near ground
422.923 : 22407 [L-FMU/MOTOR]safe_near_grd:true


#14

@thepushercg…Unless I am corrected, the best I can conclude is being that the aircraft was in AutoLanding, the VPS was indicating that the aircraft was close to the ground, but due to the inconstancy of the VPS signals, the FC determined that it was safe to shut down, regardless of what the altitude reading was. The VPS indicated 0 ft when the motors shut down.

455.801 : 24051 [L-FMU/FSM]near ground
456.166 : 24069 [L-FDI][CTRL]: fault on , tilt_ctrl_fail
456.405 : 24081 [L-FDI][CTRL]: fault off, tilt_ctrl_fail
456.722 : 24097 [L-FMU/MOTOR]safe_near_grd:true
456.845 : 24103 [L-FDI][CTRL]: fault on , tilt_ctrl_fail
456.862 : 24104 [L-FMU/MOTOR] Stop. reason:roll over or atti fail


#15

It’s the old 1- 2 punch. At 408 secs the Smart Battery system calculated the battery capacity where a landing would be required to be 62%. That was when the remaining capacity was at 58%. This caused the auto landing sequence to start.


411.965 : 21859 [L-FLYMODE][Ctrl<8>] REQ_BATTERY AUTO_LANDING ctrl_auto_landing


#16

then would you say i might have had the gimbal guard blocking the vps and this was the main factor in its demise ?


#17

@thepushercg That is a distinct possibility. I have seen the altitude issue with partially blocked VPS but not to the point of shutting down the motors during autoland. I meant to ask you that exact question by the way, regarding something confusing the VPS. Personally, I leave mine off. Just preference.


#18

it was setting back behind the camera,i have since taken it off, but it was blocking the vps, i bought it jailbroken so i am not sure if a setting was on or off that might have killed the power also.


#19

@thepushercg It was obviously on, but reporting incorrectly. It should not be active at all at high altitude.


#20

thank you both, you are both been a great help in solving this . im sorry things got out of hand on the forum, my fault fully, so please no one take offense to me. i was wrong.