Spark never leaves ATTI mode

I have a 3 year old Spark that I’ve never been able to get out of ATTI mode, due to an apparent lack of proper GPS reception. I noticed this problem right ‘out of the box’, but thought I was doing something wrong in the software. It was just over a year later that I finally had time to work on it, and by then it was too late to return it under warranty. I have another drone that I’ve used in the interim, but I would really like to get this solved.

The Spark does show ‘some’ GPS reception; just not enough to get it out of ATTI mode. I’ve played with software settings, and just recently purchased a replacement GPS module. There was no change from the original GPS module to the new one. DJI Go 4 tells me it is seeing anywhere from 3 to at most 9 GPS satellites, but that is apparently just short of leaving ATTI. I’ve checked to make sure I have the latest firmware installed on the drone and controller.

My location is at the top of a 200 ft hill with no large tree’s within a block. The GPS app on my Samsung S9 phone detects 15 GPS satellites with rock sold reception, so I assume it has to be the drone?

My questions are:

  1. Is the GPS antenna on the module? I presume it is. If not, where is the antenna located?
  2. Is there a software setting that could cause this?
  3. Is the Spark worth repairing i.e., sending it to a company that could repair it?

Thanks for any thoughts and guidance you all might have.

Frustrated in Iowa

I’m replying to my own post. I tried everything I could with my drone short of completely disassembling it and looking for physical issues. I may still do that at some point.

Meanwhile, I purchased a refurbished Spark on Ebay and it works perfectly with my controller. I’m receiving 15 plus GPS satellites in my upstairs living room; I haven’t even taken it outside for a test flight yet! It will seem a bit ‘weird’ to fly it when it has GPS acquisition and can return home if needed.

Should be a whole new experience.