SD Card

I have put a 512GB SD Card in the Drome and the controller but keeps saying its full after one minuet

I would ask what make and model of drone do you have?

Is this the first MicroSD Card you have ever used in that Drone, if not, what Make, Model, and Size did you use before?

what is the make and type is it of the MicroSD Card?

Where did you acquire it?

Have you used it previously in another device?

Have you tried to plug it into and adapter (if needed) and inserted in a laptop or desktop computer?

If you acquired the MicroSD Card off the internet from a source like eBay, it could be counterfeit. If not counterfeit, it could be mismarked.

Have you used it previously in another device like a phone, computer, tablet, etc…

I would plug it back in and see what that device reports and try formatting it there and then rechecking the capacity in that device and see what the drones software application reports…

You really need to give us something to go on…

Inquiring Minds Want to Know…

1 Like

Hi, I have tried a 512GB and a 64GB, the drone says they are both too slow. I got them from Amazon and have used the both in cameras. I have just ordered a high speed one and will see it that works.

I would only expect the drone to take longer to write teh data…

I use a Samsung High Speed MicroSD Card and it died a couple of years ago. It was replaced under warranty, (lifetime warranty…); however, while I was waiting for a replacement, I used older cards from my old smart phones, I even used an old 512MB card, oh it was slow, but it worked fine, but when I made a video, the images stuttered, and when I shot a photo, it took a long time to write the data to the card, but it worked…

So, what I am saying is something else must be causing your issues.


I am new here, 68 years old, living in The Netherlands and love drones and pc gaming.

I am having problems with a MSD card and its not the first one with my DJI Mini 3 Pro…and my hope is that somebody can help me with that.

When I did a flight with a lot of video and photo recording, I did get that MSD card out of the drone at home to copy the files on my pc.
When I insert the card in to my (did trie several) card reader and in to my pc it is showing the following messages: “The volume has no filesystem. Check for damage a.s.o.” after that message it wants to format the card…so it looks damaged…
The weird part is that my files are all there (visible) because I can quick transfer the files to my phone (card inserted in drone) without a problem.

  1. I did stop recording after the flight before switching off the drone.
  2. The drone is off when ejecting the card.

It was happening with a former card a Sandisk Extreme 64gb A2 V30 to and with my brand new Samsung EVO plus 256gb A2 V30. Both purchased at a Camera and Drone shop.

It is my fourth drone so far…(Parrot and 3 x DJI)
Did buy my drone as a demo model (almost 2 years old) 2 months ago at the same Camera and Drone shop.

DJI Mini 3 Pro
RC RM330

Hope anyone can help or advice me…would be great…

Greetings, Bodie

This web site does not get as much traffic as other web sites. I am sorry, I cannot provide an answer, but perhaps a source to a solution…

If you do not get your answer here, try this website:

The MavicPilots get a lot more traffic and it is very DJI specific.

If you do go there, Log on, and give a short introduction of yourself in the Pilot Check In sub forum, then you can post your question in either the General Discussion or the Mini 3 subforum.

Good Luck,

1 Like

Spoken to DGI and they have said it’s a fault with the drone and to return it.

So, they will repair it under warranty. When I returned one of my drones for warranty work, I received a new one in return, remember to remove props if requested and do not include the battry.

Good Luck!

As I bought it from Amazon it’s going back to them, I’ll get a refund then order another,

Thank you for all the replies, will contact dji.
I do hope it doesnt take long to repair.


Experience and the postings from others is about a week to 10-days (postage time seems to be the longest factor…) , unless it’s an older obselete unit, then maybe longer… Good Luck!

1 Like