Samsung Galaxy Tab S2 8" (2015)

Let’s discuss using the Samsung Galaxy Tab S2 (8") with DJI GO. Share tips, the best device settings, accessories used with this device, and troubleshoot problems.

1 Like

Here are some tips/settings that’ll help DJI GO perform better on your Samsung Galaxy Tab S2:

I’ve read discussion using Samsung Galaxy Tab S2 (8"), I’ve followed the guide step-by-step at the link: [Install DJI GO on an Android Tablet or Phone (Step-by-Step Guide) | Phantom Help but still the App DJI GO 4 don’t open connected with RC of my MavicPro.
A little window open to let me choose the App, but differentely from my phone Sony Z3 5", the window flash continuously, impeding the use of the App. This happens even uninstalling the other App (Litchi) and even with the APK file DJI Go 4.
Tecnical data of tablet Samsung Galaxy Tab S2 8" Mod.SM-T719
Android 7,
Thank you for any help.

Hello flytonio6169 :grinning:, I have a Samsung Galaxy TAB S2 8 "(SM-T710) that works very well with the DJO GO 4. I had some problems a few months ago by losing the image.I found the solution ( for the moment I did not have the same problem) = change the USB cable between the remote control and the tablet.The USB cable should be inserted in most of the remote control, below.
I advise you to uninstall other applications that are not original to work with the MAVIC PRO. That said it’s a great tablet! have a good flight !

There are differences in behavior between one Samsung and another.
Don’t write only Samsung Galaxy Tab S2, it says nothing, because is true and also not true!
Apart from the differentiation between 8 “and 9.7”, there are at least 4 variants, and this is the cause of different behaviors and different repeatable problems.

Versions with and without 4G/LTE, and with different electronics, Chipset, CPU, GPU, have their importance and great influence on the behaviour.
Even the Android OS version could change the games.

These are the different versions I well know of S2, and each name begins with the suffix SM- (for example: SM-T815)
8 inch:
T710 [Wi-Fi], T715 [4G/LTE] and T713 [Wi-Fi], T719 [4G/LTE]

9.7 inch:
T810 [Wi-Fi], T815 [4G/LTE] and T813 [Wi-Fi], T819 [4G/LTE]

The most problematic, instable or unusable (and that is likely to drive you crazy) with DJI GO 4 apps, moded or not, and DJI remote controller are these: T713, T719, T813, T819.

Even when you are thinking to have finally discovered a tricky way on how make DJI GO 4 work and show your drone connected, you can aspect the next time or in the near future to be stopped again and it refuse to be connected, even after repeated restarts of all, tablet, RC and aircraft.

Seems to be a random instabilty, but this happens very frequently with the same discomforting results, ambiguous results, initially good, later not anymore, as if something happened in the cache memory or in the system preferences that create conflicts.

If you want to be ready to fly, without having these unacceptable obstacles stopping suddenly your DJI drone to ground, these Samsung tablet are probably the worst solution, despite their strong point of a good visibilty under strong light and sun.

So, if you want a good Galaxy Tab S2 for your DJI GO 4 app, these are the compatible versions:

Size 8": T710, T715
Size 9.7": T810, T815

1 Like

Hello i confirm, my tablet Size 8": T710 is top from my dji go 4 and no problem with signal lost eventually because i use a usb cable 2.0



Hi, I have a mavic Pro and a Samsung Tab S2, the latest Oct-core model which I have only just set up from new. I have installed DJI Go 4 from the Play store. The first time I connected it worked correctly, by first switching on the remote control, then the aircraft, Go 4 started automatically and connected. Everything looked good and I was happy. However, when trying again, it failed to connect to Go 4. I tried all combinations of switching on order, including letting the Go 4 to start automatically and restarting the tablet, switch on RC and AC, then plugging in the USB cable, Go 4 would start but not connect. Sometimes, I could see it quickly flash connected, then it would immediately change to disconnected. Since, I have managed to make it connect a couple of times, by re-starting the tablet, switch on RC and AC, plug in USB. However, although the splash screen says connected, when entering the aircraft, the control screen says disconnected. So very hit and miss.

I also tried clearing the defaults, so that I could have the option to allow Go 4 to open. This resulted in the option overlay constantly flashing on and off, and not being able to do anything at all with it. Re-starting the tablet didn’t help.

I then uninstalled Go 4. Cleared out all Go 4 entries on the tablet. Re-installed and went through the process of setting up again, allowing it to be the default app.

I then found this guide and have made all the changes in settings that are listed above. I still cannot get it to connect, however I try with the order of switch on. I am at a loss now for what to do.

I also have an iPad Mini 4. Go 4 and Litchi work reliably everytime time with this pad. However, I really do wish to get it working reliably with the Samsung Tab S2, as I want to sell the iPad for other annoyingly frustrating Apple iOS reasons.

I checked the compatibility list, which shows the Tab S2 as being compatible (2015 model). I previously had an older Tab S2 (2015 model) which also had similar connectivity issues, which is why I bought the iPad.

Can someone please offer assistance with this, I would be forever grateful for a reliable solution.

Hello ! :wink:I’m glad to be able to help you. I had a similar problem is the solution was to change the USB cable that connects the remote to the Samsung S2 tablet. it is also necessary that your USB cable must be connected in the part below the remote control and not the mini usb which is on the left of the remote control. since then, I have never had a disconnection. the quality of the cable also plays a role. a usb 3 is I think recommended.:raised_hands:

Hi youpi4,
Thank you for the reply. I will try other cables. However, I don’t think I have a USB3 type. If the other cables I have don’t work, I’ll buy a new USB3 type cable.

I’ll feed back what happens.

Hi youpi4,

I have just checked out USB 3 cables. The micro end is quite different to a USB 2 micro connector, it is a double connector that will not fit the Tab S2 USB port. There is however, a cable that is USB3 compatible at the B connector end, and a standard USB 2 micro connector at the micro end; I suspect that this will make no difference, as the Mavic Pro RC is only USB 2.

As a matter of interest, do you have the same tablet as mine? A T719 with Octa-core processor,and which version of Android do you have installed: mine has 7 installed. I have seen that some people have downgraded Android to version 6 to make things work.


I think a top quality USB 2 cable would have to be the possible answer

it is good that try various cable you will find the right one. good luck ! And good fly

I have tried every cable I have - no go I’m afraid.

ahahah Phil ! dont afraid, did you make the last update of your tablet? I think is already done. I saw that you have tested many possibilities already. Did you put the cable that enters the remote from below? for my part I start like this: 1) my tablet and i already plug the usb cable / 2) my drone / 3) my remote control (so remote look for the connection. It may take 1 min. so that everything connects and it works very well. the only way to solve my problem was to change the cable. I have somewhere once it took a USB cable capable of transmitting data … so a cable thicker than a flat or thinUSB for example. ; O)

however, there may be signal loss but it is very rare. But you know, I also heard that on iPads that are 100% compatible this happens too! The best way to fly safely is in these cases: 1) set the home point / 2) control your drone at sight so that you can make him come back to you … even if you no longer have a visual connection on your tablet. I had sometimes the case and I was happy not to have gone too far from my sight. I heard it and I was able to guide it without crashing towards me.

I have done everything that you have done, and I only ever connect USB to the back socket on the RC. I use the side RC connector for charging the RC. I have a top quality USB cable; it doesn’t work with that either. Yes, my tablet is up to date with the latest update, and I have the latest Go 4 app.

I do have my my home point set for safe return, and always calibrate at new locations. My setup is a safe as it can be, including range limits.

So, unless I can get this working reliably on the S2, I shall keep the iPad, as it has never let me down.

It’s frustrating. I’m not going to revert to an earlier Android version as this would affect my warranty. So, it may not be possible to resolve this at all.

Thank you for your input.


Hello Phil, everything seems perfect! it’s a shame because the s2 is so convenient

I use it for almost 2 years now with my mavic and apart from a few small disconnections, rare, without gravity I am very happy.

(I do not think you have to go back to the previous version of Android my actual version is original, is not rooted and is: .)

Have you the t710 model too ?

I capture my videos and photos directly on the internal memory leaving at least 5 Gb of space.

after i copy in my inserted micro-SD card : 200 Gb, everything is going well,

I still think of something:

if you do not have the same model as my tablet, does your s2 have a GSM connection? (mine does not have any, I’m not connected to the internet at all when I’m flying. The wifi is on but not connected to any device too ).

It should perhaps, in this case, cut the mobile connection, not to be on Internet or data transfert at the same time (if it is the case on your tablet).

Maybe it would have an influence on the cuts?

I’m sorry for you.


sorry: my Android version is:

from 11.26.2018

my Dji Go 4 version on the tablet is:

DJI GO 4 v4.3.14 (735-googlePlay)

Hi, sorry I’ve been away for a couple of weeks.

I have run out of things to try but with no reliable success. So I am now keeping the iPad Mini 4 specifically for the drone. I have uninstalled DJI Do 4 on the S2.

So, there we are, a working solution.


There is a way to fly Tab S2 even T-819 version. Litchi is working with it but everything must be connected and powered on in specific order.

  1. Disconnect and power off controller, tablet and drone
  2. power on drone and controller
  3. when green lamp on controller is on connect tablet to usb cable
  4. now you can power on tablet and run litchi

It works with my Phantom 4 pro v2