DJI Drone Help Forum

RTH consistently misses by 100 to 250 feet

I’m a relatively new drone pilot, flying my Phantom 4 for about 6 months. Although I have been able to solve most problems through reading forums and manuals, I’m having one serious issue that I simply cannot solve and hope that someone here can help.

My P4 never returns to within 100 feet of its Home Point. I mean never. The Flight Log link below is from a short test flight I did this morning. Before flying, I calibrated the IMU and the compass. (For the compass calibration, I purposely went away from all metal and even removed my cell phone, watch, etc. from the drone area.)

My RTH altitude was set at 50 m.

I flew out about 615 ft horizontally from the Home Point at an altitude of 135 ft. I initiated RTH at 1m 53.6m. The P4 ascended to its correct RTH altitude and headed home in the right direction. But it stopped returning and started to Auto Land at 2m 46.3s at a distance of 254 feet from the Home Point. When it had descended straight down to 82 feet altitude, I cancelled RTH and brought it back manually with no problem.

This happens every time I use RTH and I can’t help but think there is a problem with my bird’s navigation system. Or is there something I am missing? Any help or advice will be welcomed and appreciated.

Thanks.

1 Like

Your TXT flight log does not show why it started to auto land at 2m 46s. Maybe take a look at the DAT flight log? You might find some more details there related to the RTH activity.

I’m a bit confused about .DAT files. I was able to find .DAT files on my iPad using iTunes on a Windows computer, but also able to download .DAT files using DJI Assistant. I tried looking at both types using CsvView, but with not much luck.

Can you direct me to something that explains how to view and analyze .DAT files?
Thanks.

You’ll need the DAT flight log from the aircraft. Follow these instructions.

Hello ,

I also have a Phantom 4. For months I was having issues with RTH not working properly at all. I would press RTH, the P4 would rise and rise then hover in place, never making any movement back to home. I also had forward moving at very slow speed.
Finally after reading / searching like you, I found I downgraded the firmware. I had the newest firmware and simply uninstalled it and put in the release before that one , then all problems were solved. Try that if you have not , Good luck !

Hey SkyTango4.
After spending hours last night and this morning learning about .DAT files and how to interpret them, I just tried your recommendation to downgrade the firmware on my P4. Lo and behold: RTH worked perfectly, landing within a foot of the home point. Also, although I can’t really confirm it, it seems that my drone now flies much faster in P-mode.

Anyway, thanks for your reply and suggestion.
–JN

That’s great , I’m glad it helped. I Called and texted DJI about this and they said they would get back to me when that firmware was corrected. I’m have low expectation they will. So I’ll happily leave it with the downgraded firmware , as it’s working well :).

I’m glad it worked out for you as well.

1 Like

If I had a nickel for every problem post that starts with “I upgraded my firmware and now…”

1 Like

I just sent DJI a support request about the possible bug in the latest P4 firmware. Maybe they will issue a fix.

New to this forum but not to flying.
I’ve had the exact same issues as SkyTango4, hovering with no RTH and very slow. Like him I downgraded my firmware. I still have to have most of the OAS disabled to get it to fly fast, and RTH.
I initially thought that because I was using a new Pro 4 plus remote with my older P4 that this was causing the problem, but it sounds like it is more than that ! With the newest firmware enabled I had to disable all but downward sensors to get it to RTH and fly fast. I wish DJI would bug fix their firmware, because this is a PITA to not have OAS enabled to fly the thing !
Cheers, Rick