DJI Drone Help Forum

Phatom 4 pro v2 "Version mismatch. Update all modules." Cannot take off, when UAV is warm

Hello all,

I need help for my P4P v2, please!
My drone started to show error message: “Version mismatch, Update all modules. Cannot take off!” But I updated all modules to the latest version. I tried to downgrade the modules, but with no luck.

Few attempts later I noticed, I can arm my drone, when it was powered on from “cold” state (room temperature: about 20°C), but after few mintues, the error message is shown “Version mismatch…”. After this error message is shown, I have to power off the drone and wait 30-60 minutes to cool down, and I can arm it directly after power on.

I downloaded the AC’s DAT files, and I noticed, the following log entry:

15.731 : 491 [L-FMU/LED]action changed. rc completely lost:(0)

It is very interesting, because I think the connection is OK, beacuse:

  • the video stream is shown on my phone
  • I can adjust the gimbal up/down
  • when I move the rudder stick to right and left, the gimbal moves litle bit right and left

Few other info. When this error is shown:

  • sensor data (acc, gyro, compass) in GO 4 app shows N/A
  • FC version in About menu shows N/A
  • The flight mode is jumping randolmy between ATTI, GPS, VISION states in every seconds.

My guess is: it can be a temperature based error. Might the connection between the FC and the 3in1 main boardis broken when it is “warm”. The 3in1 board reveives the RC signal, but after few minutes the FC board beleaves the RC signal is lost.
I tried it out in the garden (there was 8-10°C) and it worked for 20 minutes, the connection was OK.

I found a similar post on DJI’s forum, the guy mentioned, he had the same problem, the 3in1 main board was replaced: https://forum.dji.com/forum.php?mod=redirect&goto=findpost&ptid=195429&pid=1926390

I attached the AC’s DAT files:
Outside (8-10°C) worked ok: FLY362.DAT - Google Drive
Inside (22°C), “cold start”, I could arm one time only: FLY364.DAT - Google Drive
Insed (22°C), “warm start”, I couldn’t arm: FLY365.DAT - Google Drive

Thanks,
Peter