DJI Drone Help Forum

Phantom4 firmware update failed problem

Try switch the control radio freq from 2.4 to 5 GHz

hello everyone. I had the same problem . I and in addition I do not manage to update the firmware.
and if we check my dear friend well you will see that there is no firmware by connecting the drone to the computer you will have the list of updates and the previous version which is 0.0.0.0 which is not signed of existing firmware.
this is for I had to buy a new dji phantom 4 controller card I replaced it but still no solutions. sincerely me its tiring me so far i don’t know what to do i still find the solution.

if someone can help us it will be good i emprie you help us.

Please refresh and factory reset your drone by Dji assistant2.

Good morning dear friend. I already tried all of this but I still don’t have the solution. Tou as if I no longer have firmware in my drone. I have version 0.0.0.0.0

This is what its gives me. Current version 0.0.0.0.0

V02.00.700 plese try this update. Same problem in my drone I try update some time but my problem is not solve. Please talk me what is your overall status.

Which country to belong you.

Me I am in Benin. And I have had this problem for quite a while, sincerely I still cannot find a solution. I tried all versions to update it but no results.

How? You will solve the problem. Please reply me.

Bjr dear friend. In fact I am looking for the solution while hoping that its going to work. I ordered a part necessary for this kind of problem. From my analyzes and my diagnoses I found that the problem comes from a very important part. This is the motherboard (the 3 in 1 main board of the phantom 4 dji)