DJI Drone Help Forum

Phantom 4 Pro V2.0 - Uncontrolled ascent & drift

I am flying a Phantom 4 Pro V2.0 and have had issues with the aircraft ascending above maximum altitude settings. Also experience uncontrolled drifting when no controller input or flight plan engaged. Using drone mostly for mapping and was previously using Drone Deploy until issues started to arise. Have switched to Drone Link for flight planning and still having issues. Maximum flight elevation set in DJI GO 4 app is 122meters (400feet). Most flights plans are set up at 150 feet to 300 feet ATL. Return to home set at 90 meters (295.2 feet) The aircraft continues to be very unreliable in flight. Even when flying freehand in DJI GO 4 App, it will start to climb, then I take finger off the left joystick and it will continue to climb without input.
Warning signal comes on “Max Motor RPM Reached” when no input to controller and it continues to climb way above safe flight altitude and above all settings in the DJI GO 4 app. I have updated firmware on both drone, remote and all 3 batteries, calibrated remote, sent flight logs to DJI and they said their engineers would look into it. No response from Flight Log info that was sent to DJI and synced. Was flying a site recently, drone started to climb above 400’ well above the flight plan level of 300’ so I disengaged from the flight plan and tried to manually fly it home. It was difficult to get back as the inputs were very slow to respond and felt like drone was being controlled by someone else as i would take fingers off the controller and the drone would continue to drift without input from controller and flight plan was suspended. I sent the drone and remote into DJI after having to park it in a bush upon returning from flight that it ascended above 400’ AGL and was drifting so bad that it was unsafe to land it on the hard quarry floor without knowing i would significantly damage it trying to land as its drifting, and they are saying it is functioning properly when they tested. Tried flying it yesterday after receiving back from DJI and every flight was still having issues with uncontrolled ascent and drifting of the drone. Also have a DJI Mini 2 that flys great, without any issues on the same iPhone 10X Max. I am Part 104 and feel that i can no longer fly the P4 V2 until this uncontrolled ascent/drift is resolved so any assistance would be appreciated.

Link to a flight log
https://drive.google.com/file/d/1TRGGzqBFegUS85Ez9ouLmdPKlxAvmGOh/view?usp=sharing

-Kris

WOW… VERY ODD… not sure I heard of this happening.

My first thought was to do an IMU calibration, but 1) assumed you did that and 2) I read you sent it into DJI and they found nothing. Assuming DJI checked to make sure it was on the latest FW (which I don’t believe has been updated in a long time.

I like that you tested another drone on the same IOS device to rule that out.

Very curious to hear what happened and what resolved this

Oh forgot to ask this… You made several references to unstable in high altitudes. What about lower altitudes - any difference?

In this flight it appears the ultrasonic or infrared height sensor was stuck showing the height was very close to the ground. This occurred while the P4P was ascending and finally reaching a height of 510 meters. During this interval the OA frontDistance sensor was indicating 3 meters. Almost certainly these are faulty readings and probably the cause of the uncommanded ascent and erratic lateral movements.

WOW… all that from that graph, impressive.

What does OA stand for please?

Curious why DJI didn’t;t find this. Should he contact DJI with this new info see what they say?

Obstacle Avoidance.

I suggest that @Kris see if there is something obscuring those sensors. Maybe he can get it fixed without another trip through DJI repair.

@BudWalker @DeputyDawg Thank you both for taking a look at this.
Your correct that the altitude shown on the remote controller shows a very low and inaccurate altitude when in inflight. Gave me chills to review the graph from the flight log that @BudWalker posted… its been terrifying to fly this drone lately with its unpredictable flight patterns. I will take a look at the OA sensors and see if there is an obstruction as this is very likely. I fly it with a Klau PPK data collector and there could be some interference with the mounting of the PPK unit on the landing strut and small battery on the other strut. Your insight is very much appreciated as this has been challenging to identify the root cause for myself and DJI support. Thanks again and I will now look for the OA sensors and the placement of the auxiliary survey components that are onboard.
-Kris

1 Like