DJI Drone Help Forum

Phantom 4 Pro controller charging problem

Hi All, brand new to this and looking for some help with my controller. I haven’t really used my drone in a while and it was stored in my closet for months. Last time I used it I noticed I couldn’t get the battery past the second LED light of the battery level and not it won’t charge.
I saw some YouTube videos on it but still hasn’t worked. When I have the controller powered off the first white light is the only one that blinks and after a few minutes it stops blinking and if the controller power is on the red light is steady and first white light stays blinking indicating it’s charging. I took apart the cover on the controller and took off the battery connector for a few seconds to maybe reset it and reconnected the plug and still the same.

I then took it off again and applied the power to see if the LEDS would all flash but it only blinked the first LED.

If I connect the battery and take off the power it starts to beep. I saw on a video about applying heat to the board around the battery & power connectors but not sure if that’ll help.

Do you think a new battery will fix it or it’s something more than that…
thanks!

Either that or replacing the battery (if it’s bad) are the likely fixes. If you’re not sure which is the cause of the problem and/or are not comfortable experimenting with various possible fixes, you could send it to a repair shop.