Phantom 4 Advanced Controller Purple LED

Hello Everyone,
I’m new to drones, I have wanted one for many years and have just picked up a second or possible third hand Phantom 4 Advanced. It looks in fairly good condition will all parts included.

A couple of days ago when I picked it up I managed to get it to take off in my backyard and then land 2 or 3 times without any issues. I got a notification in the DJI Go 4 app saying that the geolocation and safe flay zones needed to be updated. I purchased an OTG cable and ran the update on the drone, whoch said it was successful.

Now when I power the controller on the left most LED turns Purple. The app can see the controller but not the drone itself.

I have plugged the drone into the laptop and run the DJI Assistant 2 app and made sure the drone in on the latest firmware. When i connect the controller the app does not see it.

Anyone know whats going one and can offer some help to a drone newbie?


I thought I would play around a little more and was trying all different button combinations C1, C2, shutter or record as found on other sites. I managed to get the LED to turn White & Green but when I powered it off and back on it turned Purple again.

The DJI Assistance 2 application from the PC said it was not supported. I did they a few times and then I look down and the LED was Red. I quickly tried to pair the remote again and it now works.

No idea how I fixed it, I’m just worried it will happen again.