DJI Drone Help Forum

Phantom 3 pro (no Video)

No camera display on Android phone or tablet.

Everything was working fine around 2017, then I got a msg one day on startup saying update required, after update camera was not displaying. It would still fly.
I was packing to move to Arkansas so didn’t fuss with it.

It has never been crashed.

Now Oct 2019 I pulled it out of closet and on start up it said update required again to 1.11.20
Relinked RC to copter. Both manual and with software.

still no video.

Things I’ve tried
Format ssd card and attempt to update again
IMU calibration
Gimble calibration
no damage found on gimble ribbon cable.

Tried many different USB cables and phone and tablet.

It flys OK
camera is taking pics as I can put ssd in pc to view pics

Any help would be appreciated.

try removing SD card then starting up as normal. If vision then shut down, reinsert SD card & away you go.

I’ve tried that and get a msg on display (no SD card) didn’t make a difference.

I found this link of value (in the process now)