DJI Drone Help Forum

P4P Battery would not recover from hibernation


#1

I had not flown my P4P for sometime, and both batteries had gone into hibernation state. Using the guidance “turn it on, wait 5 minutes, then retry to charge”, I was successful in recovering one. The other one kept blinking one LED, then go out. Then it just stopped blinking, and I cannot get a response now at all. Unless there is some other procedure I’m unaware of, I suppose I’ll have to purchase a new one. “Then I’ll have to find the firmware update that included the batteries” ::frowning:


#2

Was this after you attempted to turn it on or when you tried to charge it?

DJI GO will prompt you to update the battery firmware for the current battery if needed. If you see no “Inconsistent Firmware” message pop up, then you’re good to go.


#3

Hey Mike…after I tried to charge it, and turned it on.
On the battery firmware…do I need to plug into DJI Asst, or will it upgrade via WiFi?


#4

It sounds like it’s dead.

You don’t need to use the DJI Assistant 2 application or be connected to Wi-Fi in DJI GO. The firmware is already on your drone, so nothing needs to be downloaded. If you’d like detailed instructions, start at step #21 here.


#5

Thanks Mike …you’re the best!


#6

Mike - got a “as new” battery from Amazon for $100. Charged right up, put it in the P4P, and checked the battery status on the GO4 app. One cell shows 4.24V vs others at 4.25V. Put my other one in, and it has similar inconsistent readings of the 4 cells-off by 1 digit. Does this suggest a potential issue, or is my paranoia kicking in? I hate to admit, I only watched remaining overall voltage before.
(BTW, you were right about the battery update, the GO4 app showed “inconsitent…swipe right to update” and I watched the new batteries lights blink on/off, then “update success.”
Dan Slagle


#7

I wouldn’t worry about that small difference. It’s not unusual for all cells not to match 100%.