DJI Drone Help Forum

P4A Will not connect using DJI Go app

Over the last three months, I had several instances of the app not connecting to the drone. Now it is a continuous problem.

The P4A runs just fine with the controller alone. I have swapped out USB cables, put the phone/tablet into aircraft mode, and a variety of suggestions, to no avail.

I have several devices which I might use with the P4A, and they all have the DJI Go 4 app installed. At one time, all connected to the P4A, and now none of them will. I have reloaded the app, and tried various sequences of starting the aircraft, RC and tablet or phone. Nothing works.

THEN I tried running Kittyhawk, which I had installed on one of the phones, but never used. It talked with the P4A. So I installed it on the tablet that I wanted to use (brighter and larger screen) and it worked there!

I contacted DJI, and they asked for Kittyhawk made video, which I provided. Their response was to send the unit in for evaluation.

Before I send in a low time P4A for who-knows-what evaluation, I figured I would do a little more digging.

I think I will buy Litchi, and see if that will connect and run.

I am open to any suggestions. Thanks.