DJI Drone Help Forum

P3S controller - Broken or Repairable **SOLVED** See post 13 **


#1

I’ve asked this question on another site but no joy.

I’ve just purchased (2nd hand) my 3rd P3S controller to modify. I’ve just checked it out but noted that it has paired ok with the P3S, I have gimbal control and visuals but the drone doesn’t respond to any stick movement this includes starting and stopping motors etc.

Nothing on DJI Go app telling me there’s something wrong either. Before I take this thing apart and start prodding about, has anyone else experienced similar ? Is this repairable ? If not I shall send it back to get another. Your assistance is appreciated.

Can’t help but feel if forgotten to do something with it … old age is a terrible thing ,


#2

Hi, sorry to hear about your problem. I’m sure one of our top brains will have an answer for you soon. In the mean time I’m assuming you updated your controller software and that you are not currently in a no fly zone of any kind. That is about all I can offer. Good luck!


#3

I’m in a class D fly zone which isn’t an issue here. Everything else looks good. I’m going to try a go over it again tomorrow night in my ‘shed Quarters’ and see if I can get to the bottom of it.


#4

Again I’m no expert. I downloaded and reread the entire P3S manual (P3S was my first bird, loved it. Mavic Pro now). The only mention of motors not starting and no stick control was being in a no fly zone. Double check with a program like B4UFly to make sure you’re not in a temporary no fly zone. Also, just for kicks, calibrate your compas to be sure it’s not reporting a bad location. Finally, be sure you are not switched into beginner mode. Happened to me early and thought I never would get of the ground.

I know how frustrating this can be. I’m sure it’s something simple. Good luck.


#5

It’s definitely a controller issue and nothing else, my other 2 controllers work fine with it. :+1:


#6

Any differences in the firmware version on all of your remote controllers?


#7

There doesn’t appear to be. But to double check, I turned everything on, separately paired each remote with the P3S, my 2 original remotes work 100%. The unmolested remote again responds to gimbal movement but not stick movements.

So, I refreshed the software on the drone with the unmolested controller linked. The refresh worked fine but again, no response to stick commands. I separately re-paired the other 2 controllers and again … 100% functioning.

I’m stumped now, there are no red lights or warning triangles etc on the app or the remote. According to the app everything is good … but clearly not.

I’ve never come across this before, short of tearing the thing apart is there anything else I may be missing ?


#8

I was referring to the firmware on the remote controller. You can find the installed version and/or upgrade/downgrade it like this. Make sure your Phantom is powered off before doing this.


#9

Oh right. I was under the illusion the P3S controller (as it is unlike the P3A or P3P controller) did not require such a thing to be done. Now you have me thinking … I will go and check that shortly and let you know :+1:


#10

No, nothing is happening. I was on the understand the basic P3S controller can’t have firmware upgrades and the micro connector is solely for charging, is this not correct ?


#11

The manual (on page 52 user manual P3s) states:

“Connect to the Internet, launch the DJI GO app. The DJI GO app will start checking for available firmware updates automatically. Follow the on-screen instruction to update the latest firmware for the aircraft, remote controller and intelligent flight battery.”

Give it a try, also check all the areas for setting parameters. There may be a menu item for upgrading or downgrading the controller firmware. It’s possible it got a bad upgrade that buggerd something. If not that, I think I would send it back.


#12

Yep! I linked a video above that shows how to access that hidden feature.


#13

Ok … just spent hours in my ‘Shed Quarters’ with this controller and I’ve figured it out.

As previously stated, no error messages, red lights or warning triangles etc in the App. I knew I was on the latest firmware but I refreshed anyway … no change. Everything all good to go but no motor start.

I suspected from the outset it was a controller issue and I was correct. In mode 2 the left stick has full range of movement and the correct response. The right stick however doesn’t. Up and down it responds correctly but there is no left and right response therefore no motor start.

I’ll take it all to bits tomorrow and repair it, I will let you know the results. Thanks to those who responded for your efforts. :+1:

+++++SOLVED - Controller repairable +++++

So after realising that there was an issue with the right controller joystick, I took it all apart. I removed the right stick mechanism in its entirety and went on the hunt for either a new one or secondhand one. Little did I realise how rare they are. There were many Phantom 3 Adv / Pro controllers for sale for a lot of money but I stumbled across a Company in Surrey called TFix. They were advertising parts for a broken up Phantom 3 Adv / Pro controller. On closer inspection of the pictures, to my mind, the joysticks looked exactly the same as the standard controller. For the sum of £13 with free delivery to me here in Northern Ireland I purchased the item.

This morning (a day earlier than stated) the part arrived. I have just fitted it to my controller, re-calibrated the joysticks through the DJO Go app and ‘hey presto’ … 1 x fully functioning controller. I have just taken the P3S out for a check flight using the repaired controller and all is well.

I will now dissect the broken joystick to see if the issue with it is terminal or otherwise.

Points to note :

  • Not every issue with a ‘Controller’ is a software issue. Always try to think of other things, think logically and methodically.
  • If you take things apart, do it carefully and know where everything goes. Take pictures if you have to as a reminder.
  • Do your ‘homework’ when looking for parts, quite often some parts are interchangeable.
  • There are alot of ‘Sharks’ out there charging a lot of money for things that should be cheap. Example, I paid £13 for this with free postage, another seller had a similar item for well over £30 … at least ‘Dick Turpin’ had the courtesy to wear a mask !!!
  • Never throw anything away unless you know for fact it is broken / unrepairable / unserviceable.

I hope this is of some use to anyone who may be experiencing similar issues.