DJI Drone Help Forum

P3 Adv Camera Issues

Really enjoying this forum. I bought a used P3 Adv on ebay several months ago and I’m fully aware of the “buyer beware” slogan. I didn’t want to spend a lot to learn to fly a drone. The thing flies great and and I’ve had no major mishaps other than some hard landings…teaching me to catch the thing now. But the camera section has never worked, although the camera does respond to the gimbal angle adjustment on the controller. The status message on the flight screen (top center) always reads “Disconnected”. The aircraft signal icon to the left of that remains dim and does not illuminate like the other icons across the top of the screen. I cannot bring any camera functions up on the screen either, the camera control box on the right of the screen simply doesn’t respond. I’m having fun with it and had no idea of the complexities of these little machines, but it would be fun to take some photos and videos now. From my limited research it appears I might have a bad gimbal board. Is there a series of trouble shooting steps to check out and isolate problems with the various systems on this drone? I have more questions but thought I’d start with this issue first.

What firmware version are you using? I hope you did not try to change it. That can introduce new variables to your issue. Both AC and RC please.

I have not changed anything since I got it. But how do I check what firmware is in the RC and AC? I’m not very tech savvy but I’ve gotten this far…it’s all part of my learning curve with this project.

You can see that within the APP. I don’t have a screen shot handy but maybe @msinger does.

Also, I always ask new users if they have the full manual and have read it more than 3 times before flight.
If not, here is the link: P3A Manual
And if you are in the US, have you registered with the FAA.

I did go to the settings screen yesterday and on the “About” page, it listed: App 3.1.52 and the Basic Fly Database 01.00.01.09. I bought a 16 GB micro card and down loaded a zip file from DJI onto it but got stuck after that. I can find that file if you need more info.

You need to be connected to the aircraft to see the firmware version. The settings screen on your device does not tell you. You have to use the Pre-Go4 app. This is for all aircraft before the P4. Also are you using Android or IOS?

I do have the Pre-Go4 app called DJI Go. I am using an Android tablet. I do have a full hard copy manual that I’ve read ten times but am still finding new and interesting things. I’m trying to walk before I run with this and am enjoying the learning curve of this aircraft. And it’s good we are starting with the basics here. Their complexity is amazing. I will get connected with the AC and see what firmware info I can find. Thanks for helping me start the process. I downloaded the P3 Adv firmware v1.11.20 onto my 16 GB micro disc.

STOP! Do not change the firmware until you know what the issue may be. This as I said will introduce a new variable and will be impossible to troubleshoot if that does not work. Use what you have first, then proceed after exhausting other possibilities. I am still flying with 3 year old firmware with no issues and the latest GO and Litchi apps. And with a P3A.

In the process of trying to get the camera to function it obviously needed a micro card…whole other topic of formatting cards etc. I’ll connect the AC to the RC and see if I can get you the firmware info you need and not do anything further as we walk through this. However, with my AC signal icon not lighting on my flight screen and the flight status bar reading “Disconnected”, can I still get that firmware info from the AC? Or might I have to do some direct connection? The RC in on the charger right now. Thanks again.

To be honest, the aircraft should not even fly this way. When you get things set up and connect to the aircraft, check the status light on the RC. You should have a green light there once connected. If that remains red, you may need to re-link. We can go through that process later. As a note, the firmware versions must match between the RC and AC, and not necessarily number wise if it is older firmware. For example I fly with 1.8.8 on the aircraft and 1.6 on the RC. Those are matching firmware versions. Also, the latest for the P3 1.11.20, has known transmission issues but vary from aircraft to aircraft, so if your firmware is older, I would hold on to it.

One additional note…what device are you using. I know you said Android, but what device specifically and what version of Android. That could make a difference as well. Just trying to localize your issue prior to making significant changes.

Thanks for working with me. The mobile device (tablet) that I’m using…and you’ll love this…is a Chinese IBOPAIDA tablet. This will require some explanation. There is a bit of a parallel control going on here with my neighbor, Jim. He is an electrical engineer and and hobby computer science guy. He has a P3 Pro that’s been sitting on a shelf for years. When I got my drone I asked him for advice on buying a tablet. He said that in trying multiple tablets with his drone, the only ones that worked were the ones with cell phone capability, even without SIM cards. So he steered me to AliExpress and we looked online for tablets. He came across this tablet, on sale, with deluxe features (great screen, lots of RAM and Memory for a tablet, really nice and fast quad processor, dual SIM card capability, etc, etc.)…$148 and free delivery. He bought one too and uses it with his P3 Pro with no issues at all. It appears to be Android 8.1. I just connected my RC to the AC in the kitchen and could not find any firmware info from the AC. Again, the AC signal icon is dark and the status window reads “Disconnected”…but it’s ready to fly.

Not true…You do not need cell phone capability. If you want maps you only need wi-fi. The maps can be cached before flying. I will admit however that Android is picky.

When you connected the aircraft was the RC status red or green? 8.1 is “Oreo” and should be fine.
Can you supply a screen shot of your device that exhibits the “disconnected” status?

RC status was green and the after 30 seconds of blinking “yellow” on the AC, it’s status lights blinked green too. That’s been the scenario from the beginning and it’s ready to fly. It’s getting late here in NC, but I’ll be happy to take a picture of the screen in the morning and share it. Thanks again.

Don’t feel like the lone ranger…If you notice my ICON you can tell where I am…Take your time…

BTW, I don’t see an icon to attach a photo to these conversations. Am I missing something?

Click here to upload a file…

Good Morning, Thanks for the upload visual, I was looking for a paper clip icon. I think I’ve got two good photos for you of the flight screen, both with the RC status light shinning green. I hope this helps.

Ok, looking at the snapshot, this could very well be the gimbal board. There is nothing being transmitted from the aircraft to the Device, BUT not necessarily so to the RC. I say that because the flight data is transmitted along with the video stream. I would try 2 things. First with that device, try another USB cable. Second, try a different device. If the results are the same then I would say that it is indeed the board.
You can also check the gimbal ribbons.