No Image Transmission Signal - Aircraft flashes Red, Green, Yellow

I have a Phantom 4 Pro V2 that from day one has had the issue of “No Transmission Signal”. In the beginning it would hook up within 5 or so minutes, but now will take 30 minutes or more to hook up, if it does at all. Before I understood all the issues, I had sent it back to DJI for repair. they had updated the software, etc. and it worked. However, they did not turn the drone off for 5 minutes and turn it back on to see it would once again display the “No Transmission Signal” error.

I have tried new and different Micro SD cards, gimbal, compass calibrations. Refreshed software, factory reset, older softer version, etc. to no avail. I have searched the web for answers and been unable to find any that fit my situation and work. I manage 5 of these drones for my work and we have never had this issue. This is a personal drone I purchased for myself.

If I update or refresh the software, the “No Transmission Signal” error goes away and the drone works like it should…until I turn it off. Then when I turn it back on it gives the “No Transmission Signal” error. I have tried several android and apple devices, both ones that are approved and ones that are not to no avail. I have literally tried everything I can think or find recommendations for.

When I turn everything on, the controller hooks up with a green light. The drone’s gimbal, does its rotations as they do when turned on. Then it points forward and cannot be moved by the controller. The controller is “green” and the drone flashes Red, Green, Yellow (looks orange) which means “Turning on and Self Diagnostic Testing”. It does this continually, until the drone hooks up or I refresh the software. The controller will disconnect from the drone off and on, I believe due to the drone doing the self diagnostic? Sometimes, I cannot refresh the software unless I hook the drone to a computer.

If I “refresh” the software, it hooks up instantly, until I turn it off again. Obviously this is not doable due to not having cell service in many areas. Lately, the “No Transmission Signal” won’t go away until the software is “refreshed”. I joke that the drone likes a car ride, because I will sometimes put it in the vehicle to drive to where I can get cell service and it will hook up. As you can imagine, this makes it difficult to fly projects where battery changes are needed.

Is something loose, does anyone have other ideas? I am at my whit’s end and am about to send it back to DJI again, before the warranty runs out, but am afraid they won’t truly “test” the issue by turning it off, letting it sit for an hour and then trying to turn it back on to see if it works.

Any help is appreciated.