DJI Drone Help Forum

My iPad 10.5 Pro will not be seen by the controler Phantom pro 4

I have done all the updated to the Phantom Pro 4 drone and controller thru my PC with assistant.
I have read tons about that this iPad pro 128 should work. But it seems like I can’t get the connection happening. I even tried 2 separate lightning cables. I tried rebooting the controller,the iPad,the DJI go app all different ways.
I can do everything perfectly thru my Samsung Galaxy 8. Can anyone help or does anyone use the iPad Pro?

If you’re sure the Lightning cables are good, then the next logical thing to try would be connecting the iPad to iTunes and restoring it.

Ok, I just did that and it needed updating.Thanks for the idea. But it did not help.

What do you see on the screen in DJI GO when the tablet is connected to the remote controller?

It does not show the camera picture from the camera like it does with my phone. If I restart everything I do get the green light on the controller but the controller does not see the tablet. Very frustrating ,now looking at other tablets to get me flying.

Are you seeing the “Disconnected” message at the top of DJI GO? Or something else?

Yes it says Disconnected top left corner

You’ve tried all of the commonly used fixes for this issue. Since this is a mobile device supported by DJI, I’d recommend you contact DJI Support to see if they know of anything else you could try.