Mavic Pro IMU Calibration Failure - A quick note for your information

Hi All

I took my MP out of hibernation today and immediately hit a problem. I did the Database update no issues. All the batteries charged and functioning 100%. Aircraft checked over and new blades fitted even though a change wasn’t required.

After turning everything on and got the iPad, controller and aircraft talking to each other the error message ‘Compass Calibration’ and ‘IMU Calibration’ required flashed in red.

I completed the Compass calibration with no issues then moved onto the IMU calibration. This wasn’t happening in any form. The IMU calibration kept failing. After approx 20 attempts I put it down, had a cup of tea whilst racking my brains.

After the tea I went back to it but this time with a difference. Instead of starting the calibration in the first horizontal position as shown on the prompts … I stood the MP on her back legs and started the calibration from that point. This worked like a dream, the IMU calibrated correctly going through all the steps but in reverse order.

Since then I’ve flown the MP doing various checks whilst in the air and she flies like a dream. After each flight I’ve double checked the app going through all the settings and no issues found.

Whether it was a blip because she wasn’t used for 4 months or so I don’t know. Moral of the story is … if you get this issue on IMU calibration, then try doing what I did first before you run to DJI looking for expensive repairs to be done.

I hope this helps anyone who may need it.

AMAZING!. This worked perfectly!. Had the Calibration Failure problem before and took it to my local DJI dealer. He fixed it and I was very relieved when he only charge me $75.00. I bet he knew this trick! Thanks Astrix I owe you a beer …

Great !! I’m glad this worked for you without expense :+1::+1: