DJI Drone Help Forum

Mavic Air Video Signal Loss at Close Range

Hi all. I’m brand new to the forum. I tried to get help on the DJI forum without any takers on this topic. I did search for similar posts prior to posting this, so if I somehow missed an obvious answer, a simple link to the information I need is sufficient. Here’s my post from the DJI forum:

Ran into a problem today flying my Mavic Air, which I’ve had for less than three weeks. I’ve logged about four hours of total flight time without issue, but today I ran into the following situation. I’m curious if anybody has any ideas what went wrong.

I was out flying in timberlands in Western Washington State, USA. I was in a clearcut area where most of the trees had been cut down in the past so the area was wide open with no wifi interference anywhere in the area. I flew for about 12 minutes, total distance was something like 5000 feet horizontal, max height 392 feet. I did three recordings in cinematic mode for a total of 2 GB data. I had previously deleted all earlier videos off the card, so these three files were the only data on the micro SD. Once I was ready to land, I maneuvered the drone to my approximate take-off point and brought it down to 40 feet. I was planning on landing manually and still had something like 38% battery left, when suddenly I get an error message stating that the video signal had been lost. The screen on my iPhone 10r went black - no video feed from the drone.

I adjusted the RC antennae so that they lay horizontal to the ground, which should have been the best orientation for the drone directly above me. That did not solve the problem. I tried to bring the drone down manually using the left joystick and the drone did not seem to respond at all. Being a bit worried, I just hit the “land now” button on the phone screen and the drone came down and hovered at about the four foot level. I attempted to move the drone a bit forward and to the side with the right joystick to position it above the landing pad, but the drone still did not respond to the RC joysticks. I held down on the left joystick to land it, and whether that action was what made the drone land (in the dirt) or whether the “land now” program did it (without receiving any input from the RC), I’ll never know.

I’ve attempted to Google similar problems, and many responders cite a full micro SD card as often being the cause of this problem. None of the people having video signal loss problems describe loss of RC control when this happens. Others recommend rebooting the RC and the DJI app to restore signal, but I didn’t know to do that at the time. I was worried to fly the drone again without further research, but I’m still at a loss as to the source of the problem. Any suggestions you might have would be appreciated. Thank you!

I did eventually call DJI support. The drone seemed to be functioning normally after that incident, but they recommended I refresh the firmware and recalibrate the IMU, which I did. I did review the flight log on the DJI app, and there seems to be no data after the drone lost feed and seemed unresponsive at 40 feet. Anyway, I’m just trying to preclude this from happening again in a worse situation, so any help you can provide is appreciated.

So, you were standing directly beneath the Mavic? If so, that’s the worst place to be signal-wise. Readjusting the antennas so the flat sides are pointing directly at the aircraft is always best, but that doesn’t always resolve the issue.

You could try looking for hints in the DAT flight log from your mobile device. You’ll need DatCon to view that data.

You may be correct, but at some point, it seems unavoidable that the drone will not be above you when you land from any sort of altitude and you are near the landing pad. I don’t see on any discussions anywhere about signal transmission and antennae position stating that the operator should not be directly beneath the drone. Re-orienting the antennae did not solve the issue, though in my mind, it should have. I appreciate your input, but this problem feels more like a firmware glitch than a drone or true signal problem.

I descended from 152 feet directly overhead, no horizontal movement. At the 40 foot elevation, I get a Video Signal Loss warning and the display went black. I attempted to descend manually using the left joystick, but visually, the drone did seem to be responding. RTH did not take over as it should have. I just hit the Land Now icon and it came down. If it had been 1500 yards out, this would have probably turned out to be a much more difficult situation. I was lucky on this one.

I reviewed the program and a sample data log on that website. I’m sure I don’t have the knowledge to understand nor interpret the information in the data log. I may upload the flight information the future if no one has any reasonable ideas of what might have gone wrong.

Thank you again for your help!

Right, you won’t find much on that topic. This old video from DJI shows the direction of the aircraft signal when it’s directly overhead:

I was not necessarily assuming your location caused your problem. I was only noting that it’s the worst place to stand signal wise.

You’re right on that. It makes total sense that the vertical drone antennae have the least exposure to signal from the RC when it is right above you. A good call, though at 40 feet, I don’t think that was the cause of my total video signal loss - especially after so many flights at the 300 - 400 feet range directly above me, where the signal should have been exponentially less than that at closer range. If that were the case, I would expect that I would have had previous experiences with signal loss, or at least one occurrence on a similar flight where I had some warning of signal loss rather than just a total failure.

Who knows, the truth changes on a daily basis. Maybe you’re right on target. Clearly, the science and software in droning seems to always be in a bit of a state of flux. Appreciate your efforts. Thank you.