DJI Drone Help Forum

Mavic 2 Pro controller doesn't connect to computer

I installed the simulator on my Windows 10 PC. As directed, I also installed the usb file so the simulator recognizes the controller (dji_usb_5512_64_108.exe). The controller was recognized once, crashed and never worked again. Tried re-installing it. Nothing>

Any clues on how to get this dji controller working with the simulator (I am using the usb / controller cable that came with my DJI drone to connect to the computer).

I’ve also followed online tutorials… installed DJI assistant 2 for Mavic and also reinstalled all the software to start fresh. Very frustrating. :confused: So much money to purchase this and built a computer for the simulator in mind…and the controller can’t even connect. grrrrr

My system - built to edit my dji footage and use the simulator.
Intel Core i9-9900K (5.0 GHz Turbo) (16-Thread) (8-Core) 3.6 GHz
Motherboard: ASUS Prime Z390-P (Intel Z390 Chipset) (Up to 2x PCI-E Devices) (No SLI Support)
System Memory: 64GB DDR4 3200MHz Digital Storm Performance Series

It sounds like you did everything DJI suggested. Did you reach out to DJI support to see if they could assist?