Map Viewer Tool

Hello. I just purchased your program and its a great job to ease log management and associated details. I’m new to drones but have always enjoyed data analysis.

With respect to the map viewer, it was initially working with no issues but now seems to have stopped with the error message noted in the screenshot below. The only thing that changed was that I installed Google Earth Pro after viewing some of my maps and viewed the 3D models. I’m not sure if that as anything to do with the issue, however, but it’s all I can think of that changed after I installed Flight Reader. I also tried doing an uninstall of Google Earth and a complete uninstall and reinstall of Flight Reader to no avail.

I’m running Windows 10 under a virtual machine in VMWare within MacOS High Sierra (v 10.13.6)

Any assistance is greatly appreciated and thanks again for the tool.

Please try the following:

  1. Download Flight Reader 1.3.7 here and install it.
  2. Right click that flight log in the main Flight Reader window and choose “Reprocess Flight Log”.
  3. Click the “Map” button to view the map and verify whether or not the issue has been resolved.

If that does not fix the problem, then please send me the .HTML file generated by Flight Reader to me at mike@flightreader.com. Right click the flight log in the main Flight Reader window and choose “Open Log Folder” to find that .HTML file.

Hello Mike. Thanks for your quick response. I have sent the html file to your email, as requested.

I tried installing and re-processing as you instructed but it didn’t work on any of my six files that I originally uploaded. I then uninstalled Flight Reader 1.3.4 and deleted the original processed files and folder under the Flight Reader document directory.

I then installed FR 1.3.7 and start from scratch, all with the same result.

I’m just curious, the document file I’m loading from is from within my iCloud account. Does the file being processed and the repository have to be local or can it be a shared location?

Thanks again for your assistance .

The flight log being processed must be located on the VM where Flight Reader is installed (or a drive connected to that VM). After dropping the file onto the main Flight Reader window, it creates a copy and stores it in the Flight Reader repository.

The repository location defaults to the usual Windows user folder.

You should be able to set that location to a folder on any drive your VM is connected to.

In the attempt to reproduce what you’re seeing, I set up a brand new Windows 10 Pro VM and did the following:

  • Installed all Windows updates
  • Installed Chrome (not required for Flight Reader)
  • Installed Flight Reader
  • Installed Google Earth Pro

The map displayed as expected in Flight Reader before and after installing Google Earth Pro. So, that likely isn’t the cause of your issue.

Next, I opened Edge and dropped that .HTML file onto Edge to open it. All looked okay there too.


What happens when you open that HTML file in Edge? If the map is also loading with the same error there, then take a look at the console to find the errors logged by Google Maps. To do so, do the following:


At that point, you can refresh the webpage to see the messages Google Maps is logging to the console.

Hi Mike. Thanks so much. Experienced the same issue with Flight Reader map and in Edge until I switched the location from the VMWare shared folder location to the local C: drive associated with the VM. That did the trick! I guess the naming convention for the shared drive was too long or an issue otherwise. Again, thank you for a great tool and for your quick support. All the best!

1 Like