DJI Drone Help Forum

Lost Mavic Pro - gps position no match + speed error


#1

Hoping someone can help me figure out what happened here with my mavic pro. Everything seemed to be going normal, then says gps signal to weak, goes into atti mode. Logs also say speed error and gps position no match. I watched on my screen as it just appeared to start tumbling. Im certain I hit no obstructions, and battery was not an issue link to flight log is http://www.phantomhelp.com/LogViewer/HWD3DQLPC86TCF5GX5U8/#
Hopefully can come up with an answer?


#2

2 seconds after entering SPORT mode it dropped from 22 to 5 satellites . . barely 4 sec later you accelerated from 0 to 30mph . . quite possible an ECU could not keep up or failed to sync with what the CPU was calling for and caused both a “Speed Error” . . not sure what that is really . . and “GPS Position NoMatch” report . . but as it slowed, satellites came back and it accelerates again to almost 37mph again before it starts dropping and moving right where it crashed I assume -217ft is the surface of the river when it stopped transmitting. My guess is the rapid mode change at acceleration may have stressed it to the point of failure. Any warning notice appear on the screen when you switched to SPORT and accelerated and did you intentionally slow down and accelerate again . . or was that the Mavic failing to do what you commanded?


#3

I am still looking at this data when I have the chance. The “dropping” is from full down throttle from the RC. Just after that, full throttle up and full forward elevator. Then the Speed Errors ( Compass Errors) began. By that point the aircraft was close enough to the water that a full forward throttle would drive in right in the water. As I said, very preliminary at this point. But that is what I have seen thus far. Will post more data after looking further.


#4

When the first gps alert came on, the camera appeared to jerk. It stopped very briefly, and at that time. I tried accelarating and moving up. I believe it moved up a little before it completely went into a free fall. At no point in time did I accelerate downward in a fast motion. It all happened so fast. I will have to look at my control movements.


#5

I’m not a data analyst for these things but my experience with drone/air accidents says you did not do anything obviously wrong . . It will take DJI or someone with more knowledge here to evaluate the data


#6

Agreed. That is what the data is for. There is always a reason for an incident. Pilot error or not. Most times the data will coincide one way or the other.


#7

I kinda suspect the problem started with some kind of propulsion issue; either an ESC problem or broken prop.At 457.156 there was a drop in speed but no control inputs that would cause that.


There was also an abrupt Yaw change followed by the tumbling you saw.

The COMPASS_ERROR_LARGE and SPEED_ERROR_LARGE is commonly seen when the AC begins to tumble.

If you want to look further we’ll need to have the tablet .DAT Look here to see how to retrieve it. It will have FLY141 in the file name.


#8

Looking at the data above from BudWalker . . and being such an abrupt change in normal flight . . is it possible you hit a bird ( or a bird hit you)? You said the camera “appeared to jerk”. I’ve experienced that sudden stop in a Mavic for no apparent reason but on my video I found swallows darting in and out of view causing the collision avoidance to “brake” in mid air with no obstacles around.
Here’s a plausible cause:
A bird that was not able to avoid and broke a prop might have lead to the wild gyrations and power changes at the end . . . and it tumbled.


#9

I was thinking the same thing. The .DAT will have accelerometer and gyro data. which will show if there was a mid-flight impact.


#10

DJIFlightRecord_2018-09-06_[20-26-55].txt (747.1 KB) heres the DAT info. took a little time to load it up. I greatly appreciate any input you have. I don’t believe I hit any birds. It was mostly in my vision, and didn’t see any in the area.


#11

No, that’s the .txt you submitted phantomhelp.com. Look here to see how to retrieve the .DAT

You can change the extension from .DAT to .txt and attach it to a post.


#12

I see. loaded the wrong one. mayb this one.18-09-06-08-26-23_FLY141.DAT (3.3 MB)


#13

At 456.694 secs the right back motor started running faster, consuming more current, and being commanded higher. This is all consistent with a partially broken right back prop.



But, more interesting is the accelerometer data which indicates a collision from below and from the right.


Maybe it was a bird strike


#14

@BudWalker Bud, for some reason, I can’t get the posted .dat file to open in Datcon. Iv’e tried different versions, but get this message every time ------ 18-09-06-08-26-23_FLY141.DAT is not an acceptable .DAT file. Am I missing something here?


#15

The tablet .DAT can sometimes have a corrupted DatHeader. You can direct CsvView or DatCon to accept this.
image

You’ll notice several facts that will be missing. E.g., AirCraft type.


#16

That works…Thanks…