DJI Drone Help Forum

lost drone in trees, but I would like to understand why.

First, Sorry for my bad English…

I have absolutely no idea what went wrong and would like to know and understand this so that I can prevent such an incident after purchasing a new drone.

Word of explanation:
my remote controller is in Mode 2,

I let the drone fly 3 to 4 meters high, 17 meters far and then release the joysticks at 0m9.7S. The strange thing here is that the drone still flies a bit further until 0m14s.

At that point I realize that the RTH height needs to be adjusted, given the trees in the area, and change the height to 41m around 0M20S

I have absolutely no idea that the drone is flying to the left at that moment, at least I did not control the joysticks. That happens between seconds 21 and 27.

After I noticed on the camera that the drone is flying to the left, I tried to adjust at second 27 but that is too late and it crashes into the trees with lost of the drone…

I don’t understand at all why the drone suddenly starts flying to the left, there are no buildings, cell towers etc.in the immediate vicinity so it can’t be interference.

I would like to ask you to check the log files please because I want to understand such an incident and of course avoid it in the future.

Thank you very much! Domien

logfile

logfile airdata

I’m no expert, just looking at your AirData link. Down the left side, click on SENSORS. Then across the top, click on GPS.

I don’t know if it’s significant, but the GPS trace turns RED (poor) at the point where your drone started drifting to the left.

Now down the left side, click on WEATHER. That shows the wind direction at the time, which coincidentally is exactly the direction the drone drifted away in.

The Phantomhelp logfile link shows no control inputs during the time the drone was drifting to the left, while you were preoccupied in changing the RTH height.

If I had to guess, I’d say the drone had insufficient GPS lock at that point and switched to Atti mode. Then it was free to drift with the wind into the trees on the left.

Either that or, it was still low enough for the Vision Position sensor to be within range of the water’s surface. With insufficient GPS lock, it would first switch to Opti mode. But the optical sensor may not have had anything to lock onto on the water’s smooth surface, or it locked onto ripples caused by the wind and followed them.

All of that would still have been controllable, if you’d noticed it soon enough. But without your prompt intervention, the drone was carried into the trees.

Hi Zbip57,

Thank you for your time and answer. It makes things clearer for me.

Lessons learnded:

  • Change the RTH altitude BEFORE take off, not while in a flight!
  • always look at the drone, or camera images so you can see if it goes wrong

I have a last question. Assume i did not adjust the rth altitude in flight , would I have seen a warning in the app the moment the drone switched to Atti mode and how does that warning looks like? Just to know in the future.

again, Thank you very much, have a nice day.
Domien

I think we can discount the VPS system tracking ripples on the water’s surface. The log file shows VPS was not used.

The log shows OSD.gpsLevel at 4 throughout the flight. That’s a measure of the navigation health level on a scale of 1-5. Number of GPS satellites OSD.gpsNum starts off at 11, but then drops fluctuating between 10 to 9. And OSD.flycState is P-GPS the whole time, never flipping to ATTI.

I would think, if it lost sufficient GPS lock, it should flash some sort of message on the App. But there’s no confirmation of that happening in the TXT log.

I run a screen recorder on all my flights so I have a permanent copy of any error messages that might flash up. I’m using an Android phone with the AZ Screen Recorder app for that.

It does seem like your drone was in Atti mode though. The first indication is when you centred the control sticks but the drone didn’t immediately brake to a halt, and instead continued forward quite a ways. Then, again with control sticks centred, the wind carried the drone off to the left into the trees.

That’s certainly how it would behave in Atti mode. When the control sticks are centred, it will hold altitude, heading, and level pitch/roll attitude. It just can’t brake to a stop or hold position whenever sticks are centred.

Like I said, I’m no expert. But that’s just what it looks like to me.

There are plenty of very clever people on the MavicPilots forum who specialize in analyzing these log files. If you still have the DAT log file, that’s even more helpful than the TXT log. The DAT file should be in the MCDatFlightRecords folder under the FlightRecord folder where you found the TXT log.

Start by reading through this really informative thread:
mavicpilots.com/threads/mavic-flight-log-retrieval-and-analysis-guide.78627/

And then if you want someone else to have a look at your DAT file or TXT log, start a new message thread here:
mavicpilots.com/forums/mavic-crash-flyaway-assistance.85/

Here’s a video I did a long time ago showing the difference in GPS mode versus Atti mode. This was done using my old DJI Phantom. The controller had a toggle switch allowing me to manually select either GPS or Atti modes. It’s too bad the Mini doesn’t have something similar.

I sent all my logs to DJI. They told me:
Based on the analysis result, it seems that the incident was caused by a possible flight controller issue. However, as the aircraft was lost and we could not get it for further analysis, that was only one of our speculations. Since there was no pilot error discovered, we determined to cover this case under warranty
so we have no exactly reason why this happened,
I would like to thank you for your time and answers. It helped me to understand more the log files !!
Thanks!