DJI Drone Help Forum

Litchi update for Android 9 Pie?


#1

Last month I updated my phone (Essential PH-1) from Oreo 8.1.0 to Pie 9. This was a normal OTA update from Essential. Both DJI Go and Litchi became non-functional afterward, they simply crash/force close immediately when you start the app. but all other apps on the device worked normally. About a week later DJI updated the Go app to work with Android 9, and it’s working perfectly. I also updated the Mavic’s firmware and all is fine. I do, however, prefer Litchi over Go 4, but they have yet to issue any updates. I left feedback from the app crash, as well as feedback in the Play Store. I did receive one response from Litchi developers saying the DJI SDK was broken (referring to the Go app not working) but they did not offer any solution or comment related to correcting/updating their own software. Disappointing trying to get a developer to recognise when something is needed, and as Android 9 is by now widely deployed on most compatible Android devices, there is no reason for them not to rework their app for the new version. Certainly DJI did so very quickly and easily. Strange.


#2

You could try following up with Litchi support at support@flylitchi.com. That seems to be their preferred contact method for technical support.


#3

Just looked in the Help section on the Litchi website, Their statement on the issue says
Known Issue Android 9 Pie is not yet supported due to a crash in DJI’s SDK code which needs to be fixed by DJI.
Just emailed both Litchi and DJI, seems like they are not on the same page with this issue

I have a question regarding the Litchi app. I recently updated my Android phone which I use to fly the Mavic Pro to Android 9 Pie. There was a short period (1 week) in which both the DJI Go 4 app and Litchi would not function due to incompatibility, just force quit/crash on opening. The Go 4 app was quickly updated and works fine now with Android 9. However, the Litchi app still is not working. Tried uninstalling and updating the app, force quit/clear cache etc, still not working. I have emailed the developer (support@flylitchi.com) numerous times, but only received this response about the issue, which is stated in their Help section at https://www.flylitchi.com/help

KNOWN ISSUE - Android 9 Pie is not yet supported due to a crash in DJI’s SDK code which needs to be fixed by DJI

It appears they are disclaiming responsibility for the issue, placing the problem upon DJI developers instead. Has the recent DJI update, as it relates to the DJI Go 4 app, taken care of the SDK code problem that would affect Litchi as they claim? Or is this an entirely different problem? It appears that there is a lack of communication/understanding between Litchi and DJI code writers of the root issue causing the failure of the Litchi app. How can this problem be solved, seems like it can be fixed if both sides will listen together.

Maybe we can get them to listen to each other now!


#4

If it worked before the update can you roll it back to the old firmware. I had to do that to a Shield K1 Tablet. DJI GO4 did not like new tablet update which is android based.