DJI Drone Help Forum

Limp gimbal :-/

Hi all

My p4pro+ was working fine now when it’s turned on the gimbal starts to do its calibration but ones it goes down it doesn’t go back up … camera just slumps down and can’t be controlled from the remote :-/ camera feed works though .

I’ve tried downloading and downgrading latest firmware and factory restored etc

Is it possible to get hold of a firmware version from last year or the year before where someone mentioned they had this issue but downgraded to a firmware version that is no longer available

Thanks in advance !
Mike

Problems like this usually don’t just randomly pop up. Did you crash your Phantom? If not, what changed between now and the last time all worked as expected?

Got a link to this post?

That’s the strange thing. Never been crashes :-/

I’ve just noticed now when trying to update firmware via the remote it fails on gimbal main ESC … guessing it’s the ESC or the flex cable that’s had it … weird thing is when powering it on it attempts to do the camera/gimbal calibration (up down … then flops down … so there’s definitely power going to it

Who knows :-/