Inspire 2

Hi I am a new member and I am looking forward to be a member of your group
I have just bought a dji inspire 2 drone
My controller binds with my drone but my iPhone 13 Pro Max doesn’t bind with my controller
I am using DJI 4 go
Can anyone help Thanks

1 Like

How are you attempting to bind it? What are you seeing in DJI GO 4 that makes you think it’s not working properly?

1 Like

Hi i have tried Bluetooth and my Wi-Fi with no luck
Message on my phone says disconnected
I am using DJI 4 go

Those won’t work. You need to use a USB cable as described here in the Inspire 2 manual:


There are plenty of USB cables, some are charge only and some are Charge/Data Cables, that is what you need. the Charge/Data Cable, and some are good quality, and some are cheap, you get what you pay for and buy from a reputable dealer, not the “Dollar Store…”

1 Like

**Hi thanks for help problem solved ordered new short cable ( 12 inch ) and this worked a treat

1 Like

Congrats, now one more piece of advice, do not let the loose cable dangle, it can get caught up on all sort of things, and if the cable gets caught on something and you pull too hard, it can damage the connection…

I have ordered a short cable ( 12 inch ) works a treat