DJI Drone Help Forum

Image Transmission Weak and unable to connect to another controller

So I bought a DJI Phantom 3 Standard off someone from Gumtree earlier this week. The drone flies flawlessly and even to far distances.

However, I’ve got 2 problems with it:

  1. Once the drone gets more than ~10 metres high, I get the warning message: “Image Transmission Weak” and the image starts to get very laggy and gets stuck after around 20m height. I still have perfect control over the drone.

  2. I believe it may be a problem with the remote controller because the antenna seems to be slightly hanging by a thread. So I’ve tried using another controller from my old drone which got lost. But I’m not able to pair them because I can’t locate the linking button on the drone itself. There is the hole as outlined on this link (https://www.youtube.com/watch?v=krqYn5a5cT0) but there is nothing to press in there. I’ve tried going at all possible angles and hitting all possible locations inside the hole, but nothing seems to be ‘pressable’ or a button.

Is there another way of connecting them?

It sounds like the linking button is either damaged or has been broken off the center board.

image

Before you’ll be able to link the aircraft to another remote controller, you’ll need to repair the linking button. If you can find the button and it’s not damaged, you might be able to solder it back onto the center board. Another more expensive option would be to replace the center board.

Thanks, but is there no other way to connect the two? Using a cable or anything?

There is no other way to link the Phantom 3 Standard. You must press the linking button as shown in the video above.

I can see the red light when I look inside the hole. Does that mean the button is there as well or are they separate components?

Also the person I bought it from mentioned that he had replaced the drone with a completely new case because one of his friends had broken the previous one. Could it be that while re-assembling it, he turned the case by 90 or 180 degrees from where it was meant to be? Or is it only possible to assemble it in one direction?

Ah, well, that could be the issue then. The fact that you can see the red light likely means the linking button is intact and working properly.

While the Phantom 3 Standard components can fit inside of other Phantom 3 shells, the previous owner should have used a Phantom 3 Standard shell (Part #72) when doing that replacement. It sounds like he used the shell for another Phantom 3 model that has the linking button in a different location.

2 Likes