DJI Drone Help Forum

Help with p4 tablet

#1

Recently bought a p4 and a nexus 7 2nd gen and it wont connect to app! since worked out its the tablet. can someone plz confirm that any of the following android tablets will work with my p4 & dji go 4 app with latest firmwares.

(1)- [ASUS ZenPad 8.0 Z380M 16GB]
(2)-ASUS ZenPad Z301M
(3)-Lenovo Tab 4 8 Plus

Thank You…

0 Likes

#2

Are you referring to a Google Nexus 7 2nd gen (from 2013)?

0 Likes

#3

hi msinger. yes its the nexus 7 2nd gen sry, 2 cameras etc. wont connect to app. my phone is a samsung A5 the app worked on it perfectly but the link cable is different from other samsung phones tablets so cant upgrade fw. think im going to buy the Huawei MediaPad M3 Lite lot of good reports about it on the dji go 4 app

0 Likes

#4

I don’t use my Google Nexus 7 often, but I just tried it and it connected okay. I’m running DJI GO 4.3.14 and Android 6.0.1.

0 Likes

#5

is that the latest version of the go 4 app you have? i have already ordered the Huawei MediaPad M3 Lite. maybe it was my android version will have to check that. thx

0 Likes

#6

Yes.

0 Likes