DJI Drone Help Forum

Go App 4 map does not track live flight

I am trying to ascertain if anyone flying a Spark using the Android based Go App is able to see the white and green lines that track the Spark flight as shown in this video which however uses the Apple app version.

I am using Android vanilla 8.0 on a Cubot X19 with 4K and an OTG connection to the controller. I wish DJI could weigh in but they are quick to dismiss based on the phone not being in the supported list.

Flying this Spark around and back would be so wonderful if this feature would work, specially if you lose sight of the aircraft.

When I play back the recorded flight log, tracking works just fine and I can see all of the Spark movements and heading changes. However, when i fly it using the ‘simple’ cached map (phone has no cell service) all I see is the home and controller positions and the aircraft which does not move - even with map zoomed in.

The attitude display does show bearing correctly.

The only other anomaly I have observed is that I cannot reliably turn the histogram on - but end up having to do a photo settings reset and toggle in and out of manual mode - and if lucky the histogram shows up.

I’m using v 4.3.14 Go App 4

If you fly using Android, does map flight tracking work for you?

thank you for your help,

I just did a quick flight running DJI GO 4.3.14 on an Android device and I was able to see the green and white lines on the map. I did a second test without the maps cached and those lines also appeared.



The histogram worked okay for me too. I was able to turn it on/off and move it around.

Thank you kindly for addressing both issues.

Could you tell me which smartphone you use and how much memory it has? Which version of Android? I also assume you flew with an OTG connection.

Could you also tell me which steps you use to turn the histogram on? I first have to switch to photo mode to get to the settings toggle and when the histogram finally shows up, I then switch to video with auto exposure, then lock exposure when I have framed a mid tone view.

Now with your confirmation that the app does work correctly, it would appear to me that if I can’t consistently turn the histogram on and off -

then the problem is with the Cubot X19? It was the lowest cost phone I could find that had 4K and 2+ GHz. (It has USB-C and the plain Android is great as it has multi-language keyboard support and even FM with recording.)

I was able to run Flight Simulator OK - and I thought that would be a good load test as I had tried other phones with less memory and FS would crash on all of them.

Gosh, does that picture look good! It would so help with orientation.

thank you again.

I used an Huawei Ascend XT2. It has 2GB of RAM and is running Android 7.0. My phone was connected to the remote controller via Wi-Fi.

That’s exactly how I enabled it.

Perhaps? I’ve never tried that device.

hello msinger,

You are very helpful, I appreciate your time.
So the OS version is different and you flew with WiFi.

I’ll also assume that you are using the DJI controller.

I am amazed that your 2 GB phone is handling flight properly.
I had tried one as well - and it did fire up into camera view but it would just crash when using the flight simulator. So it gave me no confidence.

I also recall that the app was very slow to boot - whereas with the 4 GB device it starts right away. You may want to check the FS performance in the go app academy.

So your phone would be adding more load on the cpu since it has to handle an extra stream of wifi vs using OTG.

I would think it’s also under-powered with its Octa-core 1.4GHz Cortex-A53 compared to the x19. However, you have given me a couple of leads to follow.

I will see what happens with a wifi connection to the controller.
I also have another phone with similar specs to yours, that failed with FS. I had also connected that one via OTG.

In case someone is curious about the x19 here are the specs. The phone is too thick to fit in the controller so I use an adapter over the joysticks. The display could also stand being brighter. I got it from GearBest and it took forever and they said their phone did not support OTG via the usb-c, but it does - it’s really a function of Android that someone has to go out of their way to disable.


the price has gone up since I got it at $119.

I am starting to think that the OS version may be the culprit, since it seems you have less memory and processing power. The X19 actually runs Android 8.1, or perhaps OTG is messing up?

I’ll update when I run the tests.

tgjgold

Yes, I was using the DJI Spark remote controller.

It’s not the fastest phone, but it works. I bought it a while back to test it out when it was on sale for ~$60.

Yes, the DJI GO app does take a lot longer to load than other mobile devices (like my iPhone XS).

I’m not recommending anyone go out and buy the Huawei Ascend XT2 if they are looking for a snappy mobile device. It’s just what I used for this test :slight_smile:

oh gosh, looks like cockpit error.

Hopefully these maybe not-so obvious fixes help someone else avoid making the same mistakes.

I tried the wifi connection instead of the otg cable but still had the problem. I was suspecting the Android OS but that was not so.

I ran flights using a Samsung Sky Pro with os 6 and an LG phone 8.1 both with 2 GB of memory and a wifi connection. Still - I was observing the same problems. However, I did notice that the AC triangle was changing orientation correctly as I yawed and then zoomed way in and bingo - I could see the flight tracking lines.

So the major obstacle was that what I thought was sufficient zooming was not - I don’t recall having to adjust the zoom level to that degree when tracking the logged flights. Also my background is not grey as what you showed above - maybe being outdoors? I don’t think I have any control over that- which made seeing the white lines harder.

The histogram and osd switches both did not reliably turn their displays on and off, and the switch state was also not being properly restored to its last setting after exiting the settings pane.

This problem appears to be due to a UI defect with sliding the switches, as I am now able to turn things on and off reliably by tapping either to the left or the right of the switch (not sliding it). This will spare me so much aggravation when starting a flight and minimize battery waste.

I still observed an inconsistency in that when the settings screen is entered the histogram is temporarily hidden until I exit the settings. So it is not possible to adjust the ev exposure while looking at the histogram. I also have seen the histogram window with an X on its upper left allowing you to close it from the main display. Now with the tapping I never got it to display the ‘X’.

I also learned how totally unnerving it is to fly with a wifi connection to the phone or maybe because of the 2 GB memory as the video feed would start breaking up. These two other phones did not have a compass and that really is a requirement or else the outer ring on the attitude indicator goes bonkers.

I truly appreciate how helpful and responsive you were. When I realized that DJI does not respond directly to issues addressed here - I went and posted on their forum and also linked back to this one. I did receive some suggestions to try an earlier version of the Go App, which I did on the LG phone, using 4.2.24 (i think)

I will briefly refer DJI back to here. They really should investigate whether the UI switch sliding problem is just an anomaly with my setup.

For a 4GB phone the Cubot X19 gets thumbs up, with the caveat of having to adapt to its thickness but its display is brighter than the other two phones i used, even when those have the outdoor setting on. Still - could be brighter.

thanks again.

This video shows how sliding the switches is defective, which happened with all three phones and different OS and go app versions. Guess i will next find some other app that uses switches to see who the culprit is.

1 Like