DJI Drone Help Forum

Gimble moves but shows no picture on screen DJI phantom 4pro

#1

Gimble moves but shows no picture DJI phantom 4 pro

0 Likes

#2

Is this a brand new P4P?

If not, did anything happen between now and the last time all worked as expected? For example, did you crash, drop the Phantom, install new firmware, replace any hardware components, etc.? Feel free to share anything else you think we should know.

0 Likes

#3

Had it about a yr never crashed or replaced anything flew it bout a month ago and it’s been in the case put up took it out and everything works I can fly the drone have full control of the gimble system it just won’t show a picture it says disconnected

0 Likes

#4

The “Disconnected” status means your mobile device is not connected to the remote controller. Your gimbal/camera is likely just fine.

Which mobile device are you using?
How is your mobile device connected to the remote controller?
Have you tried connecting your mobile device to the remote controller with a different cable?
Have you tried updating/reinstalling DJI GO 4?
Have you tried any other mobile devices?

0 Likes

#5

It’s usually just the cable connection between the RC and the tablet that has come loose, even though it may look correct. Unplug both ends and reconnect. If that doesn’t fix it, try all of the other suggestions above.

0 Likes