DJI Drone Help Forum

Gimble disconnected


#1

I have upgraded firmware but was interupted, after that everything went wrong, no comm between controler and P4P, pink/purple light on controler and “gimble disconnected” on screen of ipod. downgraded with DJI assitant 2, no luck! use C1 C2 and exp button to reconnect controler to aircraft, no luck also used DJI ass 2, no luck, upgraded firmware again on controler and P4P, still no luck. pink/purple light on controler and still “gimble disconnected” on screen. cable is working because it is charging the ipad
Please help!!!using this as my source of income
Regards
Bossie

bossie.boma@yahoo.com


#2

Are both the aircraft and remote controller on the current firmware when checking in the DJI Assistant 2 application? If not, upgrade both to the latest version. If so, try refreshing the firmware on both the aircraft and remote controller.


#3

Yes, after the unsuccessful attempt I downgraded firmware and re-install latest on both Phantom and RC, also tried the C1.C2 and Shutter buttons, still purple ligt, yellow flashing lights on Phantom and on Ipad “gimble not connected”. redid the process a few times!


#4

Try the suggestion in post #7 here:


#5

I have tried the suggested sequence, I get the d-dd , but when I press the wheel on the right hand side I dont get the constant dddd and the light remains purple


#6

What’s the exact sequence you tried?


#7

Back ground: after initial problem I have done factory reset and the loaded latest upgrade via DJI assistant 2,upgraded my RC through Dji 4 app
Symptoms: flashing yellow lights on drone, purple light on RC and app says “gimble not connected”
Sequence 1 used: power upp RC, hold C1,C2 and shutter all together and get a d-dd bleep, release all buttons and press wheel right side of RC, NO green or blue light appears, still purple
Sequence 2 used: same as 1 but keep holding all buttons, switch off RC, release buttons, shutdown and re-start - no change
Whatever I do, the purple light keeps on


#8

Try these steps from post #7:

  • Power on the remote controller
  • Hold the C1, C2, and shutter buttons down
  • Power off the remote controller (and continue holding those buttons down)
  • Power on the remote controller

#9

Still no luck!!!


#10

It sounds like you’ve tried all of the known fixes. Try reaching out to DJI Support for help. Perhaps they’ll have some type of undocumented fix for you to try.


#11

Thanks for all your help!!!will try them


#12

If you find a fix, please come back and post it here. It’ll likely help other people who run into this issue.


#13

Wil defenitly do so!


#14

Has there been a fix for this yet? Ive ran into the same problem and tried all the fixes mentioned but still cant stop the thing from being a very expensive paper weight.

Ive only got a few more days left to film so dont have the time to send it anywhere to get fixed.

Once this is sorted I dont think I’ll ever update the firmware again! I’ve miss 3 days of filming not to mention so many man hours trying to fix it. Please help!