DJI Drone Help Forum

Gimbal Operates but No Image

Like the title says, gimbal calibrates and is able to be controlled by the remote. I am not able to get an image to show up on the DJI Go App. Also cant access the SD card from the app or use any of the camera functions.

App is updated
Firmware is updated
All connections have been checked
Tried both Samsung and Iphone apps
Unistalled and re-installed the app
even tried the cheat code to Super Contra on the remote just in case

I am not able to connect to the SD card in the camera via usb on my computer
There aren’t any lights on the front of the camera when the drone turns on.

Drone is three years old, only flown about 25 times. Sounds like this is pretty common with these.

What are my options.

It sounds like you might have a bad gimbal ribbon cable. If you want to attempt a fix yourself, I’d suggest you try replacing that cable. It commonly fixes issues like those you’ve mentioned.

You can buy an OEM DJI gimbal ribbon cable here on eBay or here on Amazon.

This video shows how to replace the cable:

If you don’t want to attempt this repair yourself, then contact a repair shop for help. You can find some repair shops here.

Thanks for the information. I will try the ribbon replacement and see how it goes.

Installed the new ribbon and the ended up with zero gimbal operation or image. I re-installed the the original one and the gimbal would operate but was not working well. I have asked for a replacement ribbon cable from fstop labs and it should be here by the weekend. I’m hoping it does the trick.

A new ribbon cable was not the fix unfortunately.

gimbal is back to operational but still no image. No camera control on dji app. All grayed out. Also read a fresh 32gb micro sd as 0gb.
Status at top of app says image signal is weak even though it shows full signal on all the indicators.

Oddly if I pan on the app where the image should be its says “action not supported during 4k” which doesn’t make sense because p3 standard of course isn’t 4k.

Any additional suggestions would be appreciated

A faulty gimbal logic board could also cause similar problems. They aren’t as easy to find though.