DJI Drone Help Forum

Flight Reader Returns Empty Log

I’ve complete 10 flights with a DJI Mini 2. On the previous 8 flights, I’ve uploaded the flight log to the Flight Reader and obtained a complete log file with no problems. For both of the last two flights, after uploading the log files the Flight Reader has returned an empty log (no entries). No error message is given. If I check the flight log using the DJI Fly app on my iPhone, the log plays back normally.

I’ve tried re-uploading the last two logs; I still get an empty result. I’ve tried re-uploading one of the previous 8 logs; I get a complete log. Any ideas?

Please either post one of those logs here or email it to me at mike@flightreader.com.

Email with logs sent, thanks!

Are you using DJI Fly 1.2.2?? I heard the way DJI generates the logs may have changed from 1.2.2

I am having same issue

Yes, I’m using 1.2.2.

That would also explain why my previous 8 flights generated complete logs, and my latest two did not; revision 1.2.2 came out a week ago, before the last two flights.

Below is the version history from my iPhone:

A few months ago, DJI started encrypting their flight logs in an attempt to prevent people from accessing them (as they stated in their forum). That change occurred in 3rd party apps using DJI SDK version 2.4.13 (or higher) and DJI Fly 1.2.2. I’m not sure if it affects current versions of DJI GO and DJI GO 4, but I suspect the same changes will be made in future updates of those apps.

Is there any hope this will be able to work for the Mini 2? I can submit a log if it will help…

Is there a solution to this? I am a new Mini2 owner and I had a problem during my first flight (using DJIFly 1.2.5)… I was told to upload the logs which I did… But the reader is blank…

It looks like I am not the only one, Is there a way to get the logs into the viewer?

Are you referring to Flight Reader or a different reader?

ohhhh… Its possible I have totally misundertstood this… I am talking about this:

https://www.phantomhelp.com/LogViewer/Upload/

And my resulting URL:

https://www.phantomhelp.com/LogViewer/HHWTEA4FCSQJCZP5YPDX