DJI Drone Help Forum

Firmware help Phantom 3 Pro Please Help

#1

do you have to update firmware in succession on a dji Phantom 3 pro?

Does anyone know what firmware comes on the Aircraft new out of the box?

I just got a new Phantom 3 Pro to replace my old one and I’m having trouble updating the firmware. it keeps failing.

I tried to update to P3X_FW_V01.03.0020.bin and it failed and now every time I try to update all I get is

“Failed.
Reboot the aircraft and try to upgrade the firmware again”
I have tried several times and no luck.

And now when I turn on the aircraft all i get is a red blinking light on the led on the front of the Gimbal.

Something I should mention: I’m using the batteries from my previous Phantom 3 pro.

which have the updated battery firmware from the previous firmware updates.

could this be why its failing?

do I need to use a brand new battery with no firmware updates on it to make it all work?

any advice would be appreciated…

Thanks

========== 2014.01.01 00:00:14 remo-con disconnect======

Packet: P3X_FW_V01.03.0020.bin

Result: Failed.

Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======

Packet: P3X_FW_V01.03.0020.bin

Result: Failed.

Reboot the aircraft and try to upgrade the firmware again.

0 Likes

#2

If you’re currently using a firmware version older than 1.3.20, then you must install 1.3.20 first before installing a newer version of the firmware. 1.3.20 needs to be installed on your remote controller and batteries. If you’re currently running 1.3.20 (or newer), then you can jump right to the firmware version you’d like to install.

It depends on when your Phantom was manufactured. There is no default firmware version for all new Phantoms.

Doubtful.

Try upgrading the firmware again by following these instructions exactly. They are very detailed, so take your time to ensure you don’t missing any steps.

0 Likes

#3

Just joined, my first comment/post. I’m an 80 year young and have a Phantom 3 Advanced, inherited from my son.

This Firmware update seems to be quite an issue. Every forum one looks at there are dozens of posts about the problems updating creates. I’m putting off updating my firmware as the drone works just fine.

My firmwares are:
App 3.1.50
Drone 1.3.20+
RC 1.9.2

I would like to go up one step to 1.04.1 to give me the Intelligent Flight modes but it will have to wait until after the weekend as I have a photo shoot on Sunday.

0 Likes

#4

It’s not a problem for most people. But, it is a common issue discussed in forums. Most people who don’t run into issues don’t come to forums to post their success stories.

0 Likes

#5

True msinger but it would be nice if occasionally they shared how they achieved success! I inherited the drone from my son who hadn’t flown it for a year+ so he made the mistake of updating directly to the latest firmware version. It totally hung the whole system up and took four hours to sort out, getting back to 1.3.20. You have to go through each update in turn!

0 Likes

#6

The Phantom 3 firmware is not as easy to install as DJI’s newer drones. However, most people who follow these instructions are successful. I’ve followed those instructions many times when installing firmware on all of my Phantom 3s and never ran into any trouble.

0 Likes

#7

Following the instructions in the above link for the RC firmware, uit would seem that my RC is up to date - it says “Latest Firmware”. Had a great couple of flights today and would hate to screw it all up but I would like to go up to 1.04.1 on the drone/battery side so that I can get the IFM…
Again, from the above link I believe I can only do the upgrade via the SD card in the drone although I do get notification of requiring an upgrade at the top of my android screen from the RC.

I think I have found/extracted the correct file - P3S_FW_V01.04.0010.bin - 66.6Mb - and I now put this onto the MicroSD root, put the card into the drone and then just turn it on having removed the gimbal lock and props…and hope!

0 Likes

#8

Successfully update my firmware from 1.3.20+ to 1.4.10+ :sweat_smile:
However, there is no sicghn of the advanced features this update should have, ie Intelligent Flight Mode, and that was my main reason for risking life and limb doing an update. Anybody know where it might be hiding?

0 Likes

#9

The icon should appear after you take off when your remote controller PAF switch is set to “F”.

0 Likes

#10

SORTED! Didn’t realise you had to have the P A F switch to “F”! All there, now need to go and play with them - in a BIG field :smile:

1 Like

#11

The PSA switch is on the P4 remote controllers. Sorry for the confusion :frowning:

0 Likes

#12

Now there’s a storm raging so have to wait to play with the new IFM settings…:roll_eyes:

1 Like