Errors in the software

I am disappointed with Flight Reader.
I only have one drone, and yet a message is sent that I exceed the amount of allowed drones. I have previously raised this error and you have corrected it.Mike. It is not my fault that DJI changes the number of digits in the drone’s number.
All right I choose to update for several drones and pay 40 dollars, but I still do not get the software updated, nor last flight. The link to support does not work. It is deeply disappointing!

I did reply to the email you sent before creating this thread.

Please make sure you have Flight Reader 1.5.37 installed since that build includes a change to merge the serial numbers together (as noted in the release notes).

After you upgraded to the unlimited license, did you restart Flight Reader? If not, your old license settings were most likely still loaded into Flight Reader when you saw the message about exceeding the allowed drones.

The program won’t even start now !
Do I have to uninstall and restart my PC and install the software again?

No. You also don’t have to reinstall anything if you already have version 1.5.37 installed (which I believe you do now).

If Flight Reader is currently running, you should see the Flight Reader icon in the Windows system tray – like this:


If you cannot see the icon, it might be hidden. Click the up arrow to see any icons Windows is hiding.

I see this:

But I still don’t see my flight ffom this year even if I resync

The presence of that icon in the Windows system tray means Flight Reader is currently running. You should be able to display the main Flight Reader window by left clicking that icon. Or right click it and choose “Open Flight Reader”.

If the main Flight Reader is not visible at that point, then it’s possible you’ve encountered some type of unhandled edge case causing Flight Reader to become unresponsive. You can manually shut down Flight Reader from the Windows Task Manager by right clicking “Flight Reader” in the Processes list and choosing “End task”. And then start Flight Reader again.

This could occur for several reasons. First, check that you don’t have any failed flight logs waiting to be reprocessed here:

If that failed button is hidden, that means no flight logs have failed to process.

Next, ensure you’re not filtering out any flight logs in the main Flight Reader window. Use the filters at the top left to show all available flight logs like this:


Next, ensure the flight logs you’re missing have been uploaded to the DJI Cloud in DJI Fly or any other DJI applications you’re using. You need to configure that syncing (like this) on all devices you’re using to fly your drones.

Keep in mind that manually syncing your flight logs in Flight Reader will only attempt to download new flight logs uploaded to the DJI Cloud since the last time Flight Reader synced your flight logs.

Finally, if you’ve done all of the above and are still missing flight logs, then try downloading all of your flight logs from the DJI Cloud again. To do so, edit your existing DJI account in the “Sync Flight Logs” section of the Flight Reader Options window, choose to sync “All available flight logs”, and click “Save Account” to kick off that re-syncing process.

I tried changing my account setup from “Only new flight logs” to “Last 25 Flight logs”, “Save Account” and “OK” - if I then check if it’s saved before I start syncing, it has not saved my setup. When I go into my account it says “Only new flight logs”
This is registered on version 1.5.37
An import of all flight logs resulted in no changes. It does not import flight from 2024. The picture with 49 error logs is from an attempt to import all logs and even after the 49 logs were imported there is still not a log from flight 2024.
Another thing I wonder about is when I look at the overview of synchronizations, the program does not record these many attempts to import:

, only the runs where there were logs that were synchronized, but it does not have to be an error, it is what the programmer have wanted to be displayed.
I will now update to version 1.5.44 and continue trying to import.

Problem solved
Made a new flight to day and uploadet the flight log to DJI, and then I made a new sync and all flights was syncronized.
Perhaps the missing flight was not registered with DJI.

That’s working as designed. When you selected “Last 25 flight logs” and saved your account, Flight Reader should have immediately attempted to sync your last 25 flight logs. The status at the bottom left corner of the main Flight Reader window should have shown those flight logs being downloaded and processed.

That setting will then auto switch back to “Only new flight logs” since it would not be beneficial to download the same last 25 flight logs every time Flight Reader syncs. Once all caught up, you’d only need to download new flight logs uploaded to the DJI Cloud.

The Sync History only shows flight logs that were downloaded. It does not show sync attempts where there was nothing to download. While I could show that, you’d end up with a history that contained mostly sync attempts where no new flight logs were found.