DJI Drone Help Forum

Drone crash


#1

Hey guys,

I was flying my drone in an open area, but near some swamp spots. I saw that my battery was about 30% so I was bringing it back to me, and when it was right above me it turned on the RTH and started to go the opposite way, not even in the direction of the Home location. I swiped to cancel it, but it kept going on because the battery was dying. Eventually it started to auto land but I couldn’t get it to come back in my direction. It ended up landing in the swamp and even with the locator and pin point area, I could not find it. I wondering why the return home setting did not go towards the right direction and why everytime i tried to override it, it kept going back to return home function.

I tried to upload the flight records, but because I’m a new user. it won’t let me
Link to the flight record: http://www.phantomhelp.com/logviewer/LYZ1IR7NG9TRHHRE26G6/#


#2

Here’s what I see in your flight log:

  • 7m 34.8s: You manually initiated RTH while your Mavic Air was hovering over the water.

  • 7m 51.9s: You cancelled RTH and started manually flying back toward the home point.

  • 11m 31.8s: The battery reached the low level and DJI GO prompted you to start flying home now.

  • 12m 46.6s: The remote controller disconnected from the Mavic Air.

  • 13m 5.9s: The remote controller reconnected to the Mavic Air and the Mavic Air was returning home since the remote controller was disconnected for more than 3 seconds. Instead of flying toward the home point, the Mavic Air was flying in the opposite direction because it was retracing its previous flight path. It’s designed to do this for up to 60 seconds after the remote controller disconnects.

    Note: The Mavic Air should have stopped retracing its flight path after the remote controller reconnected. I’m not sure why that did not happen in this case. You could reach out to DJI Support and see if they are able to explain what happened at that point.

  • 13m 20s: RTH was cancelled and you turned the Mavic Air back toward the home point.

  • 13m 24.1s: The battery reached the critically low level and the Mavic Air started auto landing at its current location (as designed).

After this point, there were a lot of confusing movements on the remote controller. Instead of continuing to fly back toward your location (like you were doing when the auto landing started), you kept spinning the Mavic Air in a circle and commanding it further away from your location.

Your Mavic Air landed at 10.777945, 106.71828. You should be able to find it there if you go to that exact location. Try entering those coordinates in the map app on your mobile device.


#3

This is really here nor there, but I don’t see the duplicate retrace in the data at the approx 13 min mark. The OP was flying back manually and I it looks like it switched to auto land almost immediately after returning to RTH upon signal restoration. At the approx 13min 20 sec mark, RTH was in progress though for only a limited amount of time. The OP moved the sticks which canceled that, returning the AC to P-GPS, then the almost immediate switch to auto land. It’s really hard to be exact with all the signal break ups. But for the most part the analysis is the same. But just to throw in a question that I have, not being that familiar with the Mavic Air’s RTH procedure. According to the manual there is a difference in time for RTH initiation. 3 seconds when using only the RC and 20 seconds if using a mobile device. Doesn’t really make any sense to me for a difference, but it’s there in black and white. Second question, again referencing RTH. I am not a fan of the route re-trace feature. It’s ok for short close in flights, but if you fly a complicated pattern just on the edge of signal range, and your battery is low, that could be a serious issue to re-trace as opposed to shortest path back, don’t you think?


#4

What do you mean by a “duplicate retrace”?

Where in the log is RTH cancelled after the sticks were moved?

That’s correct.

The aircraft will only attempt to retrace its previous flight path for 60 seconds. And if the remote controller reconnects before 60 seconds, the aircraft is supposed to stop retracing the previous flight path. That did not happen in this case for some reason.


#5

There was a previous RTH which was cancelled ( Not shown above ). The Second RTH is noted above. That is what I meant by “duplicate”, I should have worded second instead. I do not see where a flight retrace began on the second one.

Again looking at the second graph above, you will note that the sticks were moved before and during the signal restore where RTH is still active. It then switches to P-GPS which effectively cancels the RTH. Just before auto land initiates. Altitude changes slightly due to the throttle up.


#6

The remote controller disconnected from the aircraft at 12m 46s. The downlink was restored at 13m 5.9s. At that point in the flight log, you can see the aircraft retracing the previous flight path. The OP was moving the sticks, but the aircraft counteracted those moves and continued retracing. This is the only part of the flight that did not seem to be working as designed. The aircraft should have stopped after the remote controller reconnected.

Between 13m 5.9s and 13m 20.3s (the duration of the second RTH), I see the OP moved the remote controller sticks 5 times before RTH was cancelled. That’s not really surprising to me though since moving the remote controller sticks never cancels RTH any other time.


#7

Agreed somewhat. But there are two things below is a larger view of the second graph from above. Note that there was signal loss. For approx 20 seconds. Unfortunately, we don’t know where in this time frame the second RTH began. That said, you can see where it was restored. Referencing the manual again,

That said, if you look at the time interval above there were stick movements that cancel the RTH.
Like I said before, this is really just pulling hairs so to speak. The end result is the same. I was really more interested on your opinion of the RTH protocol for Re-tracing the flights for RTH.


#8

Can you take a look at the flight log itself and show me where RTH was cancelled after the OP moved the remote controller sticks? I seem to be missing it.

Also, where in the DJI manual (or other documentation) did you find that moving the remote controller sticks can cancel RTH? I’ve never come across such documentation myself.


#9

That is where the data came from, your CSV log and the Verbose CSV…they both show the same data. I think what the case may be is that before the AC switches to autoland, It has to switch to P-GPS first, before auto land. There is really nothing there, other than the stick inputs to indicate that the RTH was actually cancelled, other than what the manual states, and it could possibly be coincidental as well. The statement I posted on the RTH cancel is from the DJI Mavic Air Manual, page 14.


#10

Here’s page 14 of the Mavic Air manual. Note there is no mention of being able to cancel RTH by moving the remote controller sticks.

Manual

Yeah, there is nothing in the TXT flight log. @rick might be able to tell us what happened.


#11

I think the issue is, you may have a newer version than I do. Here is the complete page 14, from what I have. It is dated Jan 2018…


#12

Ah, yes, that would explain the confusion. I don’t even know that the Mavic Air ever operated like that. It looks like an error that has been corrected.

If you look through the flight log closely, you’ll see RTH was not cancelled after the control sticks were pulled (as described in that old manual).


#13

That is why I mentioned the fact, but what I was attempting to relay was the fact that the AC switched to P-GPS before going to auto land. That could be a normal sequence but quite honestly I have not looked in to the sequencing in that much detail, for the Mavic anyway. That does not occur with a Phantom, that I have seen.


#14

I’ve never seen the flight modes switch like that. It looks like @rick cancelled the RTH. Perhaps because his attempts to steer the aircraft toward his location failed.


#15

So was I had the drone above and was going to bring it down, the RTH function turned on and I guess it started to retrace the way it came from. I would hold the “x” to take control and cancel RTH but it would start up again. I thought it would have at least taken the shortest route to go back home because it was. Further distance. The reason I didn’t stay in the “home” position was because I wanted to keep it in my sight and also signal hasn’t been that great with the Air. I’m going to contact DJI support and see what else I can do. You’ve all been great. Thanks for the help!