DJI Drone Help Forum

DRAGON TOUCH X10 no live video feed

The telemetry is displayed, there is just no live video feed. Everything works fine. I even tried recording a video and taking a picture. It will display that normally. I also know that the drone and controller are working properly because I use this also on my Samsung Galaxy J3 Emerge with zero issues. I have even powered up both at the same time and swapped the cord between the two to see if something would work or give me a clue of how to fix this.

I have tried both ports. I have tried several different cords and reversed them if possible (mini usb to mini usb). Nothing has worked.

Reason I know this should work… I have seen this video that prompted me to buy it for the same reasons. (https://www.youtube.com/watch?v=p5ePDnWWrAU) It seemed logical that if it worked for him with the same exact set up, it should for me.

I did reach out to contact the videographer, but he has yet to reply.

I am wondering if due to the age of the video that a earlier version of DJI GO would work?
I found links and going to experiment with them. But does anyone have an answer for this? Some simple video or usb setting?
I am also trying developer mode settings on the tablet. So far I have only tried usb debugging mode. It didn’t help.

And the live video feed worked as expected when you switched back to the Samsung Galaxy J3 Emerge?

The Dragon Touch K10 doesn’t have great specs, but it does match the specs of some other Dragon Touch devices people are using. Installing on old version of DJI GO might resolve the issue.

I tried 2 of the X10s.
I don’t remember if it was the video feed but neither tablet worked but it was close.
I tried old apps too
Ended up with the nvidia shield with the hdmi port