DJI Drone Help Forum

Controller Doesn't Seam To Control Phantom 3 Standard

Well, the other day, after a full flight, I landed my Phantom 3 standard, swapped batteries, then went to take off. For some reason though, the DJI GO app wanted to install an update. I let it run all the way through and it completed successfully. For some reason though, the lights that flash yellow or green to indicate GPS status now rapidly flash yellow. I read online that this means the controller isn’t connected. This isn’t the case however as the light on the controller is green and the app is able to commutate with the drone just fine. For the hell of it, I hit the take off button on the app. The drone took off and hovered. I for some reason, couldn’t control anything with the remote. I hit the land button on the remote, and the drone landed as it should.

So, from what I can gather on this, is that for some reason, the drone is not communicating with the controller in terms of controls such as both sticks and all switches/buttons. But the app is showing full communication with the drone including the video feed and flight data. The controller is also indicating that the drone is connected via the light that is red when the drone is off turning green. And, the app is able to command the drone to take off and land.

Things I’ve tried include rolling the firmware on the drone back via the SD card, relinking the controller multiple times, in which the drone does link back up just fine. I also tried calibrating the control sticks on the remote which didn’t change anything. Remote and drone are fully charged.

Any input on this is greatly appreciated as I am lost on this. I’ve Googled for hours and haven’t found anyone with the same issue. The drone is not under warranty as it is four years old…

Sounds like a controller firmware issue.

I had to look hard but I found a 2016 reply from a DJI Forum moderator concerning a broken controller (remote) firmware installation.
Check this out:

“The remote is updated directly by the network when you connect it, open the application and your phone or tablet is connected to the internet. There should be a warning that the remote control needs updating, and if you press, following the instructions is updated directly from the network.”

5 yrs ago there were numerous gripes about “my update didn’t work” or my drone started screaming so loud I just turned it off" That’s one of the many reasons I never trusted the GO app. to do upgrades.
All I can advise is to open the app while connected to the internet an see if DJI notices if something went fubar with your latest update. Hopefully this might start you on the path to a complete firmware upgrade.