DJI Drone Help Forum

Cant go beyond the GO FLY button screen on my Phantom 4 Pro+

Hello All,

My DJI Phantom 4 Pro + does not lift because it does not go beyond the home menu with the “GO FLY” button.

Simply clicking on the GO FLY button nothing happens, nor are there any error messages. As it is not possible to pass this screen the drone cannot lift.

I refreshed the latest firmware, which is installed. I also tried going to Settings / Apps and killing all running apps / processes, and resetting the remote to factory defaults. Didnt work either.

All communications and menus are accessible and working.

The drone has made several flights without any problems until this problem arises, ie no more or further the “GO FLY” screen button no matter how much you click on it.

Can you please help on this? Thanks!

Rui

Did you change anything or do anything notable (like crash) between the last time all worked as expected and this problem started occurring?

Case closed. Here’s how I solved it:

a) Later (just for once) I could get the “Camera Sensor Error” message.

b) I changed the internal flat cable that connects to the sensor to a brand new one.

c) Everything is ok now.

PLEASE BE AWARE OF THIS: this is a common problem on these cameras. The problem is everybody will try on one way or another that you need to replace the Sensor itself. YOU DO NOT. The sensor can cost you about $800. 99% of the time YOU JUST NEED TO REPLACE THE FLAT CABLE, with costs $40.

Best,

Rui

Do you have any idea how you damaged that cable?

I dont have a precise or exact idea how the cable was damage.

As I used it for 2 years and 1 month, can only wonder if it got just old, it stood for thousands and thousands of camera movements, left and right, up and down…