DJI Drone Help Forum

Can't connect to Go App P3A

I just got this P3A and already fixed the crazy gimbal. The set screw was loose on the motor
The RC is linked and light is green
Lights blink green on the drone
I’ve tried different sequences to connect
I’ve tried different cables
Still no Go App
I tried down grading firmware by holding the hamburger icon at the top right for 10 seconds but says there’s nothing to down grade to
I am using go app before P4
Using same tablet with Go app 4 with my mavic pro and everything works fine
Ideas?

Also it’s obvious this drone has worked before and flown
Some scuff marks
I’m thinking it’s something on my end

Also I can move the gimbal and start the motors with the remote

I’m having a very similar issue with my P3A also, so this thread caught my attention. I bought my P3A used through ebay. When I first flew it I could use the auto-take-off icon where the slider gizmo appears in the the center of the MD screen. I can no longer do that and have to start it manually with “crossed sticks” now, but it flies just fine. After chatting with knowledgeable folks on another post months ago, it appears that I probably have a bad gimbal board because I have no camera functions. But is there not a separate telemetry and AC systems feed coming to the MD from the AC flight controller and GPS module? How would one trouble shoot that? My apologies if should have posted “my issues” separately, but Ms.UAV’s problem sounds a lot like mine…including flying a Mavic Pro where everything works just fine.

“I am using go app before P4
Using same tablet with Go app 4 with my mavic pro and everything works fine”

As quister has been advised in. another post, I’m pretty sure the P3A uses the DJI GO App, won’t work with the Go4.

Hey quister, no problems posting here.
I used to have a P3A and now things are jogging my memory
I feel a bit stupid.
The dji box says for iphone and ipad. Tried the ipad and everything works
Not sure why the tablets that work with the mavic pro don’t work with the P3A.
I had the hdmi module on my previous phantom in order to use my goggles
msinger’s list includes my nvidea shield tablet but it doesn’t work with the phantom
Actually my rca voyager cheapo tablet made his list. I wanted something cheap to take camping instead of an ipad

I fly my P3A all the time with the Nvidia Shield K1. You do however have to “set it up”
Go into settings and scroll right down and turn on “Developer Options”
Using the magnifying glass search for “mtp” then “Select USB Configuration”
From the menu select MTP (Media Transfer Protocol)

Should work OK now…

Hmm, says it’s already on that setting
Maybe another setting?

Do I need to install an older version of the go app?

Not that I’m aware of. I’m running 3.1.59 which apparently was automatically updated on 11/02/2020 - I wasn’t aware that it was on auto update.
I’m busy this morning but I’ll fire everything g up this afternoon and get back if there are any issues with this latest version.

Thank you
The mavic pro works fine with the shield. It even asks me which app I want to use.
I go to the P3A with same cable and tablet and nothing happens

Just remembered something from last year. Thought I’d have a go flying with Litchi so installed it on my Nvidia. It seemed to take over and I couldn’t use the DJI GO with it there, there was some sort of conflict.
Uninstalled the Litchi and all was well again.
Maybe there is a conflict between the DJI GO and the GO4 that is preventing you using the GO??

Just a thought.

Uninstalled Go4 app and nothing changed
Even tried USB debugging
Just flipping switches at this point lol

When I connect the usb cable it says “charging” so it’s charging off the remote.
I change the usb cable to “midi” and nothing changes
The developer mode is still set to MTP

I just tried my LG phone
Mavic works fine
P3A no go

Yes I think you do need the debugging turned on…are you still getting green light on RC and green flashing at back of drone?
Do you see any feedback from the drone camera, battery state etc?

Yes, everything works and flies great with the ipad
In the airdata notifications i get “motor is blocked”
I think I have to turn off something in the txt files to false
Working on that issue now

Can’t figure out why the Shield won’t work so I bought a cheapo $35 RCA Voyager and it works fine and msinger put a similar one from me on his compatibility list.
Put an hdmi module on the controller and can use my goggles
Doesn’t make any sense to me why tablets are so picky with an app