DJI Drone Help Forum

Can't Connect, or Even Get Phone to Recognize Remote Control

I’ve been at this for almost 5 hours now, and making no progress.

The DJI Go 4 app (on OnePlus 6T) doesn’t seem to be able to connect to either the remote control or the Mavic Air.

I downloaded DJI Assistant 2 to my PC, and successfully updated the firmware of the Mavic Air to latest version. I attempted to do the same for the remote control, but when I plug in the USB, the PC repeatedly connects to and disconnects from the remote control, and the DJI Assistant 2 application never recognizes that it is connected to the controller, so updating firmware (or even just checking firmware version) on the RC seems to be impossible.

Exceptionally frustrating first day with this thing. I sure love the build quality, but this is ridiculous. Any suggestions would be greatly appreciated.

Update:
Whatever the issue is, it seems to be with the OnePlus 6T. Tried the same thing on a Samsung tablet and an old Google Nexus 6 smartphone, and in both cases, everything worked fine on the first try.

Did you try connecting the OnePlus 6T to both the left and bottom ports on the remote controller?