DJI Drone Help Forum

Android connection problems

#1

Hi Guys
I’m new to this site and have had a Mavic Pro for just over a year now and love it, I bought a brand new Samsung S2 “8” tablet to use ONLY with the Mavic so apart from loading on the GO4 app its totally clean wi fi is off, It used to connect to the aircraft with some difficulty but now its really hit and miss…mostly miss, I have given up as a few times its taken half an our to eventually connect, by then the Mavic battery is no longer 100%.
I have contacted DJI they said my device is not on their compatible list ??? I didn’t know there was a list !!
Anyway I have now resorted to using my Tesco Hudle (uk) which is an ancient relic really but works every time.
I just wondered if anyone out there has com up with a fix, I have tried switching on the Tablet last which used to work.
Dillon

0 Likes

#2

You can find DJI’s list of supported devices here. In addition to their supported devices, you can find a bunch of other devices that people are using here.

Depending on where you look, some people say this tablet works with no tricks and others are saying there is a certain order that needs to be followed each time. Those differences are likely due to the different tablet models, versions of the OS, and/or versions of DJI GO 4.

When you switch the tablet on last, is it completely powered off and connected to the remote controller before you power it on? Some Samsung S2 owners are saying that works for them.

0 Likes

#3

@Dillon. This could depend on the actual S2 model. What is the SMT-XXX model of your S2? I run the SMT-710 with zero issues. There are several different models.

0 Likes

#4

Hi thanks for the reply, yes the tablet is powered off and connected to the RC via USB, the tablet does try to charge and draw power from the RC even though its switched off, I don’t think there is an option on the tablet to stop it charging temporarily, once everything else is switched on the tablet is fired up last, this used to work intermittently but now its fails almost every time.
The model Samsung No SM-T713 Android 7.0 version T713XXU2BSA/T7130XA2BSA1/ Latest updates are installed.
Thanks for your input

0 Likes

#5

@Dillon
The tablet is not actually charging. You need to change your USB settings under “Developer Options” which is a hidden menu in Android. Go to “About Device”, Tap on the “Build Number” several times, you will finally enable “Developer Options” The USB setting is in that menu.

0 Likes

#6

Hi already enabled Developer options, USB is set to MPT protocol, the charge option is not checked.

0 Likes

#7

That is what it should be. Do you have USB Debugging enabled?

0 Likes

#8

Yes Debugging is enabled.

0 Likes

#9

Hmmm… Ok try this power up sequence.

  1. After connecting the tablet to the RC. Power up the tablet. ( Do not start the app ) and make sure the tablet home screen is unlocked.

  2. Power up the RC. ( You may get a pop up, or you may not )

  3. Open GO ( If that is what you will be flying with )

  4. Power on the aircraft.

  5. Wait for the home point to update.

This is the way my 710 works flawlessly with GO or Litchi, BUT if you have both you have to set the default app when the RC is powered up.

0 Likes

#10

Hi Guys thanks for the input I don’t have Litchi only the GO4 app on my tablet, will try the sequence next time I fire up the Mavic, thanks Fly_Dawg

0 Likes

#11

I tried the above sequence it failed on the first attempt, I then close the GO4 app and re-opened it then it worked ok ! I then opened and closed the app twice more and it worked fine, fingers crossed it behaves itself from now on, thanks for the input now I’m happy !!
Thanks Guys

0 Likes