Almost new Phantom3 Advanced Connection problems

I bought an almost new Phantom 3 Advanced. No trouble connecting and flying with an Apple Tablet of about 8 years old. Just bought an Apple Tablet ipad (9th generation) Wi-Fi and cannot get it to connect. Multiple people have tried. Any solutions??

Assuming the App is running fine in all other aspects, Check the cable, try a different cable.

I would also check this listing and see if other folks are using that device.

I would also consider performing a complete Reset of the Device to get rid of all old apps and junk files.

Good Luck!

Opps, forgot the link…

Thank you for your reply. Thought about it last night. No other aps on this tablet. Simply down loaded the same app as worked with older tablet that belongs to the friend that is experienced. I know that phamtom 3 is no longer made. The tablet brand new and there have been no other apps even downloaded.

Am wondering if any others have problems with a new tablet recently offered. But even more important is if someone has used a tablet only available during and after 2021 and 2022.

Am thinking about simply buying an older tablet.

Try this Forum, it’s DJI dedicated, with a lot of old time droners…

LT signing off…

If you are having issues getting DJI GO to work with a new tablet, Try using Litchi. Personally I prefer it over DJI GO due to the autonomous flight planning primarily. If you have never used it, you can read about it at the link below. It is compatible with every DJI Aircraft except for the Mini 3 at present.