DJI Drone Help Forum

Aircraft Disconnected to from Controller

When I attempt to connect my controller via iPhone to Mavic Pro I get an error on the iPhone/DJI Go 4 error message “Aircraft Disconnected”. I have installed the latest DJI Go 4 application. I even invested in a new controller and encounter the same error. Any ideas would be appreciated.

I have a few questions for you:

  • Is this a brand new Mavic that has never been flown? If not, what changed between now and the last time everything worked as expected?

  • Did you link the new remote controller to the Mavic?

  • What do you see on the remote controller screen when both the Mavic and remote controller are powered on?

The Mavic in not new. I have owned and flown it for 14 months. Never crashed, I am not familiar with the link process of the controller. The controller screen has a red message banner: “Aircraft Disconnected”. Thanks for inquiry and feedback.

So, after 14 months, the aircraft just randomly stopped connecting?

Whenever switching to a new remote controller, you must link it to the aircraft like this before you’ll be able to use it:



The remote controller has a black and white LCD screen. Are you referring to the red message at the top of DJI GO on your mobile device?

When you power on both the remote controller and aircraft, which message appears on this screen?

image

The Aircraft Disconnected banner appears in the upper left hand corner of the DJI Go app.

Do you have a Mavic Pro? Or are you flying a different type of drone?

Mavic Pro!

I just wanted to double check since it started to sound like your remote controller didn’t have a screen.

Please do this (and only this):

1) Power on the remote controller.
2) Power on the aircraft.
3) Wait 10 seconds.

What do you see on the remote controller screen here?

image

READY TO GO OPTI MODE

That means the remote controller is connecting to the aircraft. Your issue is that DJI GO is not connecting to the aircraft (via the remote controller).

Here are some things to try (in this order):

1) If a cable is connected to the Micro USB port on the left side of the remote controller, remove it. The USB port on the remote controller will not work when that cable is connected.

2) Connect your iPhone to the USB port on the bottom of the remote controller with a different Lightning cable. This will rule out a faulty Lightning cable as the cause.

3) Reinstall DJI GO 4 like this.

Who are you. I am a seasoned systems engineer. You methodical approach and subsequent isolation of project was extremely thorough. It worked. I appreciate your help.

Tony Huguely
Http://www.linkdn.com/in.huguelad

I guess I get that from my software engineer background.

How did you end up fixing the problem?

I to am a seasoned software engineer. I backed up history files and deleted all remnants of the GO 4 application from my iPhone X. It work liked a charm as directed. Thanks again very much. Tony Huguely.

1 Like